Open Bug 536546 Opened 10 years ago Updated 1 year ago

[Autoconfiguration] Add support for inbox.lv and inbox.lt domains

Categories

(Webtools :: ISPDB Database Entries, defect)

x86
Windows 7
defect
Not set

Tracking

(Not tracked)

People

(Reporter: abuse, Unassigned)

References

(Depends on 1 open bug)

Details

Attachments

(2 files, 5 obsolete files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
Build Identifier: 

please append attached xml files to https://live.mozillamessaging.com/autoconfig/ 

Reproducible: Always
Attached file autoconfig for inbox.lv domain (obsolete) —
Attached file autoconfig for inbox.lt domain (obsolete) —
Attachment #418995 - Attachment mime type: application/octet-stream → application/xml
Attachment #418996 - Attachment mime type: application/octet-stream → application/xml
Attachment #418995 - Flags: review?(bwinton)
Attachment #418996 - Flags: review?(bwinton)
Comment on attachment 418995 [details]
autoconfig for inbox.lv  domain

It passes all the sanity checks with flying colours, so my only nit is that the spacing is a little off, but if you run "xmllint.exe --format inbox.lv", it should clean that right up.

r=me with that change.

Thanks,
Blake.
Attachment #418995 - Flags: review?(bwinton) → review+
Comment on attachment 418996 [details]
autoconfig for inbox.lt  domain

This one, too, passes all the sanity checks, and has the wrong spacing, so r=me when it's reformatted.

Thanks,
Blake.
Attachment #418996 - Flags: review?(bwinton) → review+
Comment on attachment 418996 [details]
autoconfig for inbox.lt  domain

<?xml version="1.0" encoding="UTF-8"?>
<clientConfig>
  <emailProvider id="inbox.lt">
    <domain>inbox.lt</domain>
    <displayName>Inbox.lt</displayName>
    <displayShortName>Inbox.lt</displayShortName>
    <incomingServer type="pop3">
      <hostname>mail.inbox.lt</hostname>
      <port>995</port>
      <socketType>SSL</socketType>
      <username>%EMAILLOCALPART%</username>
      <authentication>plain</authentication>
      <pop3>
        <leaveMessagesOnServer>true</leaveMessagesOnServer>
        <daysToLeaveMessagesOnServer>999</daysToLeaveMessagesOnServer>
      </pop3>
    </incomingServer>
    <outgoingServer type="smtp">
      <hostname>mail.inbox.lt</hostname>
      <port>587</port>
      <socketType>STARTTLS</socketType>
      <username>%EMAILLOCALPART%</username>
      <authentication>plain</authentication>
      <addThisServer>true</addThisServer>
      <useGlobalPreferredServer>false</useGlobalPreferredServer>
    </outgoingServer>
  </emailProvider>
</clientConfig>
Attached file autoconfig for inbox.lv linted (obsolete) —
Attachment #418995 - Attachment is obsolete: true
Attachment #419191 - Flags: review?(bwinton)
Attachment #419191 - Flags: approval-thunderbird3.0.1?
Attached file autoconfig for inbox.lt domai (obsolete) —
Attachment #419192 - Attachment is obsolete: true
Attachment #418996 - Attachment is obsolete: true
Attachment #419193 - Flags: review?(bwinton)
Comment on attachment 419191 [details]
autoconfig for inbox.lv linted

(You didn't need to ask me for the second review once you had an r+ from me.  But you do need to get someone else to review them before we can mark them as "checkin-needed". :)

Later,
Blake.
Attachment #419191 - Flags: review?(bwinton) → review+
Comment on attachment 419193 [details]
autoconfiguration file for inbox.lt domain - formatted

(Ditto for this one.)
Attachment #419193 - Flags: review?(bwinton) → review+
Attachment #419193 - Flags: review?(gozer)
Attachment #419191 - Flags: review?(gozer)
Comment on attachment 419191 [details]
autoconfig for inbox.lv linted

Approval isn't required for these.
Attachment #419191 - Flags: approval-thunderbird3.0.1?
Attachment #419191 - Flags: review?(gozer) → review+
Attachment #419193 - Flags: review?(gozer) → review+
Keywords: checkin-needed
ping for the checking
Assignee: nobody → abuse
Checked in as http://viewvc.svn.mozilla.org/vc?view=revision&revision=59087

(Sorry about the delay, I wasn't set up to check stuff in to this tree.  That's fixed now, obviously.)

Later,
Blake.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
there is the problem:
thunderbird 3.0 does not use inbox.lv and inbox.lt autoconfiguration files due 
'''<daysToLeaveMessagesOnServer>''' option inside.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
is it bug of thunderbird 3.0 or the option is invalid ?
Assignee: abuse → bwinton
Strangely enough, a bit of both.  :)

There's definitely a bug in Thunderbird, which I've created bug 538568 to track.

But 999 seems like an odd value to use.  Do you really mean 999 days, or did you mean "forever", which I think could be expressed as "-1"?

Thanks,
Blake.
"forever" is that we would like to get
Okay, so you should probably change that to -1.  It still won't work, but at least when the other bug is fixed, it'll do what you want.  ;)

Thanks, and thanks for finding that other bug, too.

Later,
Blake.
what is the default value for "daysToLeaveMessagesOnServer" when it is not set explicitly ?
7.

So that's not really what you want, I'm guessing.
daysToLeaveMessagesOnServer is "-1" that should mean "forever"
Attachment #419191 - Attachment is obsolete: true
daysToLeaveMessagesOnServer is "-1"
Attachment #419193 - Attachment is obsolete: true
Keywords: checkin-needed
That should mean forever, but let me test it before we check it in.  ;)

Thanks,
Blake.
Keywords: checkin-needed
Depends on: 556728
Component: ispdb → ISPDB Server
Product: Mozilla Messaging → Webtools
Assignee: bwinton → nobody
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
No assignee, updating the status.
Status: ASSIGNED → NEW
No assignee, updating the status.
No assignee, updating the status.
Component: ISPDB Server → ISPDB Database Entries
You need to log in before you can comment on or make changes to this bug.