crash / hang in nsCookieService::RemoveCookieFromList

RESOLVED DUPLICATE of bug 536230

Status

()

--
critical
RESOLVED DUPLICATE of bug 536230
9 years ago
9 years ago

People

(Reporter: Dolske, Unassigned)

Tracking

({crash})

Trunk
x86
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Created attachment 419038 [details]
Sample data

Three times in the last 3 days I've had Firefox appear to hang (pinwheel of death) shortly after opening a new tab.

It appears this is actually a crash, which is somehow causing the OS X crash reporter to choke (10+ minutes without the process going away), gdb hangs when connecting to the process, and our own crash reporter has problems too... We generate a minidump .dmp, but no .extra file. I manually hacked together a .extra, but the the stackwalker still choked... See bp-3955ceb0-798f-4393-97eb-8ebc92091223

I did manage to get the OS X crash reporter to come up after the first crash, as saw some frames involving cookies before it immediately closed (wtf?!). I was also able to grab some data with the "sample" utility. [Which is a little surprising, because this is a release (optimized) trunk nightly, and it usually gives bogus stacks. Maybe 10.6 is better about this?]

...
7495 nsHTMLDocument::SetCookie
  7495 nsCookieService::SetCookieString
    7495 nsCookieService::SetCookieStringInternal
      7495 nsCookieService::SetCookieInternal
        7495 nsCookieService::AddInternal
          7495 nsCookieService::PurgeCookies
            7495 nsCookieService::RemoveCookieFromList
              7495 __memcpy
                7495 __longcopy

I don't see any CPU activity when Firefox is stuck in this state, and in my profile the last two modified files are cookies.sqlite and cookies.sqlite-journal. PRAGMA integrity_check says "ok".

I've still got a couple previous minidumps if you're interested, dunno if they'll be enlightening or not. Would running with cookie logging enabled help?
(Reporter)

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 536230
You need to log in before you can comment on or make changes to this bug.