Crash when closing full screen of BBC iplayer using esc

RESOLVED FIXED

Status

--
critical
RESOLVED FIXED
9 years ago
2 years ago

People

(Reporter: colinwh, Assigned: bugs)

Tracking

({crash, stackwanted})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [FP 10.1.53.64], URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-GB; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-GB; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7

Firefox closes all together when I close the full screen option of the BBC iplayer and want to return to the small screen version of the player. 

Reproducible: Always

Steps to Reproduce:
1.Start watching a program using the BBC iplayer.
2.Go to the full screen option. 
3.Press esc
Actual Results:  
Firefox crashes and closes down


The software should have returned to the small screen version of the iplayer. The program should remain playing.
(Reporter)

Updated

9 years ago
Keywords: crash

Comment 1

9 years ago
Do you get a Mozilla crash reporter window when this happens?
https://developer.mozilla.org/En/How_to_get_a_stacktrace_for_a_bug_report

You appear to be using Mac OS X 10.4, which Apple recently stopped shipping updates for.  You should probably upgrade.

BBC won't let me watch stuff because I'm outside of the UK, so it's hard for me to test this myself :(
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins

Comment 2

9 years ago
i tried w/ my mbp running 10.5 and minefield and firefox 3.5.6 from NW London, and i can't trigger anything. I tried using both <esc> and the bottom right button, as well as cmd-tab to switch to another app. Sadly my 10.5 g5 didn't travel with me.

    Shockwave Flash 10.0 r32
(Reporter)

Comment 3

9 years ago
I have the same problem with Utube.
Colin, can you please go to about:crashes and paste the IDs of crash reports you've submitted for these crashes (as Jesse described in comment 1)?  It's impossible to tell what's going on without them.
(Reporter)

Comment 5

9 years ago
The crashes do not produce crash reports. I've tried running the Youtube at full screen and pressing ESC and Firefox just closes down. No report is generated. I have tried this a number of times.

Comment 6

9 years ago
If you go to ~/Library/Logs/CrashReporter/, do you see any reports from this crash?  Since you're on 10.4, you might have to open firefox-bin.crash.log and scroll to the bottom.

Comment 7

9 years ago
What version of Flash do you have?  Loading http://www.adobe.com/software/flash/about/ should tell you.  If *that* crashes, try Tools->Addons->Plugins in Firefox.
(Reporter)

Comment 8

9 years ago
The Flash I have installed is 10,0,42,34
Not able to reproduce on youtube.com using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 with Shockwave Flash 10.0 r42.

I have seen comments on crash stats indicating people do crash on this site, and I have seen hendrix feedback that indicates there have been crashes while listening to radio programs as well. Would be helpful to have a crash report and other information from the reporter to investigate further, although tough for us in the US to repro the problem with TV channels since we cannot watch them.
(Reporter)

Comment 10

9 years ago
I don't know how to find the crash log. I have tried searching my hard drive and can't find it. Do you have any pointers for finding the log. One doesn't appear when the crash occurs.

Comment 11

9 years ago
Hrmm, maybe it's an abort rather than a crash, and that trips up both our crash reporter and the OS crash reporter?  I suppose you could try running under gdb.  In a Terminal window,

gdb /Applications/Firefox.app/Contents/MacOS/firefox-bin
r

and when it crashes:

bt

Comment 12

9 years ago
Or perhaps you'd like to try a beta of Firefox 3.6?  We've done a bunch of things to stop Flash from crashing ;)
(Reporter)

Comment 13

9 years ago
I have moved to Firefox 3.6 and this has fixed the problem. Thanks.
(In reply to comment #11)
> Hrmm, maybe it's an abort rather than a crash, and that trips up both our crash
> reporter and the OS crash reporter?

Don't forget that Mac OS X crash logs aren't even written when Breakpad is installed (unless you've set the user default from bug 382541, which most non-devs haven't). 

That said, if Breakpad can't catch it, it's probably pretty nasty and you may not get anything useful from the OS anyway.

Updated

9 years ago
Severity: normal → critical
Component: Plug-ins → Flash (Adobe)
Keywords: stackwanted
Product: Core → Plugins
QA Contact: plugins → adobe-flash
Version: unspecified → 10.x
(Assignee)

Comment 15

8 years ago
FP 10.1.53.64 fixed a number of issues reproduced with the BBC Player.
Assignee: nobody → jet
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Whiteboard: [FP 10.1.53.64]
(Assignee)

Updated

8 years ago
Target Milestone: --- → Jun 2010

Comment 16

2 years ago
Version and milestone values are being reset to defaults as part of product refactoring.
Target Milestone: Jun 2010 → ---
Version: 10.x → unspecified
You need to log in before you can comment on or make changes to this bug.