Closed Bug 536670 Opened 13 years ago Closed 11 years ago

Space characters stripped or changed when replying to quoted-printable message

Categories

(MailNews Core :: Composition, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 448198

People

(Reporter: stanio, Unassigned)

Details

(Whiteboard: dupme)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.6) Gecko/20091206 SeaMonkey/2.0.1 (Spidey; Mnenhy 0.7.6)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091204 Thunderbird/3.0

Space characters get stripped or changed in the quotes of an original message when replying.  Seems this happens when the original message uses quoted-printable content transfer encoding, and replying to it using plain text composition (either have "Compose messages in HTML format" unchecked or holding Shift while pressing the "Reply" button).  It also appears to happen when:

mailnews.send_plaintext_flowed=true

which is the default.  The problem is not seen when mailnews.send_plaintext_flowed=false, or composing in HTML.

Reproducible: Always

Steps to Reproduce:
1. Import the email message I'm about to attach (either using the ImportExportTools [IMPEXP] extension, or adding a leading "From - XXX" line and copying it to the Local Folders on the file system);
2. Reply to the message using plain text composition.

[IMPEXP] http://nic-nac-project.de/~kaosmos/mboximport-en.html
Actual Results:  
Certain text in the quotes from the original message gets some spaces stripped and other changed, e.g.:

'hgext/' from the beginning of <name>. If <path> is empty (the "foo ="

becomes:

> 'hgext/' from the beginning of<name>. If<path>  is empty (the "foo ="

Expected Results:  
The text of the original message should appear verbatim in the quotes of the reply.

Also happens with SeaMonkey 2.0.1 and current Thunderbird trunk:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1pre) Gecko/20091223 Shredder/3.1a1pre
Attached file Sample message
Note if the original message (the given sample) doesn't use quoted-printable there appears no problem.  Anyway, this might be related to Bug 448198.
Looking further this might be a duplicate of Bug 519165, also.
I can reproduce the bug on a recent SeaMonkey 2.0.2pre build [1].
Out of curiosity, it seems that mailnews.send_plaintext_flowed defaults to false on my system.


[1] Build identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.1.8pre) Gecko/20100102 SeaMonkey/2.0.2pre
> Out of curiosity, it seems that mailnews.send_plaintext_flowed defaults to
> false on my system.

It could be a preference carried over from your SM 1.* profile, or it could be just different on Mac.  I can see in <seamonkey>\defaults\pref\mailnews.js on line 620:

pref("mailnews.send_plaintext_flowed", true); // RFC 2646=======

I have always observed this as the default.  May be they have changed it for the upcoming SM 2.0.2 given the number of troubles sending of format=flowed causes currently.
(In reply to comment #5)
> It could be a preference carried over from your SM 1.* profile, or it could be
> just different on Mac.

I found it, I have Enigmail installed and it set the mailnews.send_plaintext_flowed default value to false (it may ask for it, I don't remember).
Sorry for the noise.
Whiteboard: dupme
This is clearly a dupe of bug 448198.
xref to bug 448198 for ese of tracking.
Depends on: 448198
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
No longer depends on: 448198
Resolution: --- → DUPLICATE
Duplicate of bug: 448198
You need to log in before you can comment on or make changes to this bug.