The Star Button next to e-mail adresses saves new e-mail addresses only to "collected addresses" (no choice for saving to "Personal Address Book")

RESOLVED DUPLICATE of bug 456167

Status

--
enhancement
RESOLVED DUPLICATE of bug 456167
9 years ago
9 years ago

People

(Reporter: dfghjkjhg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.1.5) Gecko/20091204 Lightning/1.0b2pre Thunderbird/3.0

Clicking the Star Button next to e-mail adresses (in new mails) saves new e-mail addresses only to "collected addresses".
There's no choice for saving to the "Personal Address Book".
To do so you can only open the address book and move the contact from "collected addresses" to "personal address book" manually (drag and drop).

Therefore:
a) Please provide a possibility to chose where to save the e-mail address to after having clicked the star button (dropdown-menu with all adressbooks).
b) Also please provide a possibility for defining the default address book in that dropdown-menu (alternatively make the "personal address book" the default by standard).

Reproducible: Always
(In reply to comment #0)
> User-Agent:       
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.1.5)
> Gecko/20091204 Lightning/1.0b2pre Thunderbird/3.0
> 
> Clicking the Star Button next to e-mail adresses (in new mails) saves new
> e-mail addresses only to "collected addresses".
> There's no choice for saving to the "Personal Address Book".
> To do so you can only open the address book and move the contact from
> "collected addresses" to "personal address book" manually (drag and drop).
> 
> Therefore:
> a) Please provide a possibility to chose where to save the e-mail address to
> after having clicked the star button (dropdown-menu with all adressbooks).

The rule in bugzilla is one issue per bug. Let's keep the one above for this bug.

This defeats the star/unstar pupose of being able to easily and quickly save an email in the address book - but I do see some value in it.

> b) Also please provide a possibility for defining the default address book in
> that dropdown-menu (alternatively make the "personal address book" the default
> by standard).

Can you file another bug for this one ?

Bryan anythoughts on these ?
Component: General → Message Reader UI
OS: Windows Vista → All
QA Contact: general → message-reader
(In reply to comment #1)
> (In reply to comment #0)
> > User-Agent:       
> > Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.1.5)
> > Gecko/20091204 Lightning/1.0b2pre Thunderbird/3.0
> > 
> > Clicking the Star Button next to e-mail adresses (in new mails) saves new
> > e-mail addresses only to "collected addresses".
> > There's no choice for saving to the "Personal Address Book".
> > To do so you can only open the address book and move the contact from
> > "collected addresses" to "personal address book" manually (drag and drop).
> > 
> > Therefore:
> > a) Please provide a possibility to chose where to save the e-mail address to
> > after having clicked the star button (dropdown-menu with all adressbooks).
> 
> The rule in bugzilla is one issue per bug. Let's keep the one above for this
> bug.
> 
> This defeats the star/unstar pupose of being able to easily and quickly save an
> email in the address book - but I do see some value in it.

And that's bug 456167
 
> > b) Also please provide a possibility for defining the default address book in
> > that dropdown-menu (alternatively make the "personal address book" the default
> > by standard).

This can be changed using mail.collect_addressbook
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 456167
You need to log in before you can comment on or make changes to this bug.