Help > Check for updates won't work

RESOLVED WORKSFORME

Status

()

Toolkit
Application Update
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: Josser, Unassigned)

Tracking

1.9.1 Branch
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_2; ru-ru) AppleWebKit/531.21.8 (KHTML, like Gecko) Version/4.0.4 Safari/531.21.10
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5

Chcking fr updates won't work. 
The system says: No updates found. 

Reproducible: Always

Steps to Reproduce:
1. Click "Help" -> "Check for updates"
2. 
3.
Actual Results:  
No updates found. 

Expected Results:  
Firefox should update to latest verison.

Updated

8 years ago
Component: General → Application Update
Product: Firefox → Toolkit
QA Contact: general → application.update
Version: unspecified → 1.9.1 Branch
Reporter, are you still experiencing this? If so, please type about:config in the url bar (press the warning button if it displays), right click in the content and select New -> Boolean.

If you are still running Firefox 3.5.x enter app.update.log.all for the name. If you are running Firefox 3.6.x enter app.update.log for the name.
For the value select true.

Exit Firefox and start it again. Open the Error Console under the Tools menu and select Clear. Select Help -> Check for Updates. A bunch of new entries should appear in the Error Console. Copy and paste the ones that start with AUS: into this bug. Thanks.
(Reporter)

Comment 2

8 years ago
I've manually updated to 3.6.3 so I checked it with the release of 3.6.4 or 3.7
Would you mind downgrading to Firefox 3.6.2 and try to update to Firefox 3.6.3?
http://releases.mozilla.org/pub/mozilla.org/firefox/releases/3.6.2/mac/en-US/
(Reporter)

Comment 4

8 years ago
I checked in 3.6.2 and all works fine. (Successfully updated to 3.6.3)

Think that it can be closed. 

Thanks!
If it happens again post to this bug after following the steps in comment #1 and I'll reopen the bug. Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

8 years ago
Seems that it happens again. 

I folow the steps in comment #1, here what i see in error console: 

AUS:SVC Checker:getUpdateURL - update URL: https://aus2.mozilla.org/update/3/Firefox/3.6.3/20100401064631/Darwin_x86-gcc3/en-US/release/Darwin%2010.4.0/default/default/update.xml?force=1

AUS:SVC Checker:checkForUpdates - sending request to: https://aus2.mozilla.org/update/3/Firefox/3.6.3/20100401064631/Darwin_x86-gcc3/en-US/release/Darwin%2010.4.0/default/default/update.xml?force=1

AUS:SVC Checker:onLoad - request completed downloading document

AUS:SVC Checker:onLoad - number of updates available: 0
Looks like you stripped the Mac OS X package since that should have Universal-gcc3 and not x86-gcc3.
(Reporter)

Comment 8

8 years ago
You are absolutely right, i used CleanMyMac. 

So the workaround is avoid to stripping Firefox binary or something should be done on the servers side (maybe symbolic link)?
Definitely avoid stripping the binary. I'll talk with the release engineering people to see what they think of providing a complete update for this case.
You need to log in before you can comment on or make changes to this bug.