Thread view presents individual news messages multiple times and omits others

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: shortcutter, Unassigned)

Tracking

({testcase})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2012-02-21], URL)

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.5) Gecko/20091204 Thunderbird/3.0

I am reading com.lang.ruby via news.individual.net.  Apparently TB confuses messages: the tree view of a thread is deeply nested yet apparently only the one (the first?) message of each poster shows up - but it is visible multiple times.  Other messages are not shown.  (I will try to attach a screenshot showing what I mean in a minute.)  The URL is a thread shown on Google Groups that exhibits the behavior on my machine.  I tried "recreate index" but the phenomenon did not go away.

Reproducible: Always

Steps to Reproduce:
1. Read comp.lang.ruby
2. View settings: threaded, sort by date
3. look at the thread referenced above
Actual Results:  
The thread repeats the first two messages multiple times and the tree looks different than that in Google Groups and what TB 2.x shows.

Expected Results:  
The thread shows the real thread, no messages are repeated.

On another thread [1] the order is reversed: my reply shows up as thread root while the original question shows up below my posting.  Maybe something with referencing articles is wrong.  Another potential source of this confusion (which I have not noticed yet in another news group) might be the fact that the news group is also filled via an email gateway so a close look at news headers might give you an idea what's wrong.

[1] http://groups.google.com/group/comp.lang.ruby/browse_frm/thread/7f8a1e68761e0c90#
(Reporter)

Comment 1

9 years ago
Created attachment 419173 [details]
Screen shots showing 4 copies of the same posting

This is a PDF containing screen shows which demonstrate how the same posting shows up at least four times in the same news thread.
(Reporter)

Comment 2

9 years ago
(In reply to comment #0)

After resize of the window in order to get smaller screenshots this second phenomenon went away and the thread is presented properly - the main issue (multiple occurrences of the same posting) is still there though.

> On another thread [1] the order is reversed: my reply shows up as thread root
> while the original question shows up below my posting.  Maybe something with
> referencing articles is wrong.  Another potential source of this confusion
> (which I have not noticed yet in another news group) might be the fact that the
> news group is also filled via an email gateway so a close look at news headers
> might give you an idea what's wrong.
> 
> [1]
> http://groups.google.com/group/comp.lang.ruby/browse_frm/thread/7f8a1e68761e0c90#
(Reporter)

Comment 3

9 years ago
Created attachment 419309 [details]
Zip of c.l.r folder and index.

Just in case it helps track down issues.
(Reporter)

Comment 4

9 years ago
Corrected platform: the product is 32 bit but the OS is 64 bit.
Hardware: x86 → x86_64
Keywords: testcase
(Reporter)

Comment 5

9 years ago
The issue is gone with version 3.0.1.  Thanks for fixing!  Setting to RESOLVED/FIXED.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
(Reporter)

Comment 6

9 years ago
The issue has popped up again with 3.0.1.  Reopening...
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Updated

8 years ago
Component: Mail Window Front End → Folder and Message Lists
QA Contact: front-end → folders-message-lists
Summary: Thread view presents individual messages multiple times and omits others → Thread view presents individual news messages multiple times and omits others

Comment 7

7 years ago
(In reply to Robert Klemme from comment #6)
> The issue has popped up again with 3.0.1.  Reopening...

Hi Robert. Sorry to ask again, but lots has changed in 2 years. Do you still see this problem?
Whiteboard: [closeme 2012-02-21]
(Reporter)

Comment 8

7 years ago
(In reply to Wayne Mery (:wsmwk) from comment #7)
> Hi Robert. Sorry to ask again, but lots has changed in 2 years. Do you still
> see this problem?

No, I haven't seen this in a while.  Sorry, I should have mentioned it but I had completely forgotten about it.  Works for me in current versions.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.