Closed Bug 536793 Opened 10 years ago Closed 10 years ago

Cannot access to translations

Categories

(Webtools Graveyard :: Verbatim, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: JasnaPaka, Assigned: zbraniecki)

References

()

Details

Attachments

(1 file)

A few days ago I noticed that I cannot see all translations on Verbatim. I'm logged under my LDAP account (jasnapaka@jasnapaka.com). I discussed about this problem on IRC with Gandalf.
yup, confirming. I investigated this bug over last two days, and it seems to be related to some data corruption in the database. The data on the drive is fine (plus the permissions are OK), but django returns errors on db queries that are related to user permissions.

I don't understand the pootle/django split in DB, but will investigate further.
Status: NEW → ASSIGNED
I spent some time debugging it, but I'm completely lost.

Dwayne, any experience with this kind of bugs?
Attached image error screen
error screen
Environment:

Request Method: GET
Request URL: http://localize.mozilla.org/verbatim/cs/getpersonas/
Django Version: 1.1.1
Python Version: 2.4.3
Installed Applications:
['django.contrib.sessions',
 'django.contrib.auth',
 'django.contrib.contenttypes',
 'django.contrib.sites',
 'django.contrib.admin',
 'pootle_app',
 'pootle_misc',
 'pootle_store',
 'pootle_notifications',
 'pootle_autonotices',
 'registration',
 'profiles',
 'djblets.siteconfig',
 'djblets.util',
 'django_extensions']
Installed Middleware:
('pootle_misc.middleware.baseurl.BaseUrlMiddleware',
 'pootle_misc.middleware.siteconfig.SiteConfigMiddleware',
 'django.middleware.cache.UpdateCacheMiddleware',
 'django.middleware.http.ConditionalGetMiddleware',
 'django.middleware.gzip.GZipMiddleware',
 'django.contrib.sessions.middleware.SessionMiddleware',
 'django.contrib.auth.middleware.AuthenticationMiddleware',
 'django.middleware.locale.LocaleMiddleware',
 'pootle_misc.middleware.errorpages.ErrorPagesMiddleware',
 'django.middleware.common.CommonMiddleware',
 'pootle.middleware.check_cookies.CheckCookieMiddleware',
 'django.middleware.cache.FetchFromCacheMiddleware')


Traceback:
File "/data/www/localize.mozilla.org/verbatim/pootle_env/lib/python2.4/site-packages/django/core/handlers/base.py" in get_response
  92.                 response = callback(request, *callback_args, **callback_kwargs)
File "/data/www/localize.mozilla.org/verbatim/pootle_env/lib/python2.4/site-packages/pootle_app/views/language/view.py" in decorated_f
  56.         return f(request, translation_project, *args, **kwargs)
File "/data/www/localize.mozilla.org/verbatim/pootle_env/lib/python2.4/site-packages/pootle_app/views/language/view.py" in decorated_f
  63.         request.permissions = get_matching_permissions(
File "/data/www/localize.mozilla.org/verbatim/pootle_env/lib/python2.4/site-packages/pootle_app/models/permissions.py" in get_matching_permissions
  103.         permissions = get_matching_permissions_recurse(profile, directory)
File "/data/www/localize.mozilla.org/verbatim/pootle_env/lib/python2.4/site-packages/pootle_app/models/permissions.py" in get_matching_permissions_recurse
  85.         permissions = get_matching_permissions(profile, directory.parent)
File "/data/www/localize.mozilla.org/verbatim/pootle_env/lib/python2.4/site-packages/pootle_app/models/permissions.py" in get_matching_permissions
  106.             permissions['administrate'] = get_pootle_permission('administrate')
File "/data/www/localize.mozilla.org/verbatim/pootle_env/lib/python2.4/site-packages/pootle_app/models/permissions.py" in get_pootle_permission
  32.     content_type = ContentType.objects.get(name='pootle', app_label='pootle_app')
File "/data/www/localize.mozilla.org/verbatim/pootle_env/lib/python2.4/site-packages/django/db/models/manager.py" in get
  120.         return self.get_query_set().get(*args, **kwargs)
File "/data/www/localize.mozilla.org/verbatim/pootle_env/lib/python2.4/site-packages/django/db/models/query.py" in get
  304.             raise self.model.DoesNotExist("%s matching query does not exist."

Exception Type: DoesNotExist at /cs/getpersonas/
Exception Value: ContentType matching query does not exist.
the above is a debug msg
fixed.

The issue is that we upgraded our Pootle instance but we did not upgrade our Pootle DB. In result we have some data that is not coherent. I'll file a separate bug to update Pootle to 2.0.0 and update the DB schema.
I said it is fixed.
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Most of the office was out on holiday, sorry we weren't able to help.  But glad you god it fixed.
Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.