Last Comment Bug 536880 - Editing text is sluggish on the MediaWiki at wiki.osdc.org.il or the wikipedia/wikibooks/wikimedia MediaWikis (on Mandriva Linux Cooker)
: Editing text is sluggish on the MediaWiki at wiki.osdc.org.il or the wikipedi...
Status: RESOLVED WORKSFORME
: perf
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: x86 Linux
: -- major with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
NA http://wiki.osdc.org.il/index.php/...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-27 10:18 PST by Shlomi Fish
Modified: 2012-08-27 14:16 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Shlomi Fish 2009-12-27 10:18:08 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2b6pre) Gecko/20091227 Namoroka/3.6b6pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2b6pre) Gecko/20091227 Namoroka/3.6b6pre

When editing the text in the page in the URL:

http://wiki.osdc.org.il/index.php/User:Shlomif/Firefox_Test_Page_No._1

It is very sluggish. Firefox profile with no extensions installed on Mandriva Linux Cooker (Cooker is the Mandriva bleeding edge) on a P4-2.4GHz (x86-32) with 2.5 GB of RAM., and latest Firefox 3.6.x from mozilla.org .

(Registration for that wiki is required, but you don't need an E-mail handshake to start editing).

Reproducible: Always

Steps to Reproduce:
1. Register to the wiki.
2. Go to http://wiki.osdc.org.il/index.php/User:Shlomif/Firefox_Test_Page_No._1
3. Press the edit button.
4. Edit random stuff.
Actual Results:  
The editing is very sluggish and it takes a lot of time for the letters of the presses to appear.

Expected Results:  
The presses should display immediately.
Comment 1 Shlomi Fish 2010-03-28 13:26:43 PDT
This still happens with Firefox 3.6.2 (from mozilla.com) on x86-Linux on both Mandriva Linux Cooker and Debian Testing Squeeze - both on a Firefox profile with no extensions. Furthermore, it also affects Wikimedia wikis such as wikibooks or the Wikipedia . See:

https://qa.mandriva.com/show_bug.cgi?id=57864

Opera is OK.

Reading from the mandriva.com bug report:

Description of problem:

firefox on Mandriva Cooker (tried in the firefox of a new user, though in an
X-windows belonging to my default user), including the one from the standard
mozilla.org binary firefox distribution, becomes sluggish after editing
mediawiki wikis for some time. New firefox profile, new user account, etc. I'll
try on a new user's account standalone X-windows soon.

I could not reproduce it from what I tried on my Debian Testing VM with the
mozilla.org firefox. 

How reproducible:

Always.

Steps to Reproduce:
1. Go to http://en.wikibooks.org/wiki/User:Shlomif-kdetest
2. Login as user "Shlomif-kdetest" with password «Gordon6000sPartan87».
3. Edit the http://en.wikibooks.org/wiki/User:Shlomif-kdetest page several time
while copying and pasting titles from the wikipedia inside a
[[wikipedia:Maths|Maths]] style.
4. Slowdown in the typing of the letters.

-------- Comment #1 From Shlomi Fish on 2010-02-25 20:33:45 CEST (-) [reply] -------- 	

OK, now I tried it in the X-Windows of a new user (ran as "WD=icewm startx"
from the command-line) with the mozilla.org firefox and it still happens there.
Very annoying.

-------- Comment #2 From Shlomi Fish on 2010-03-28 21:25:38 CEST (-) [reply] -------- 	

I should note that by

-------- Comment #3 From Shlomi Fish on 2010-03-28 21:27:28 CEST (-) [reply] -------- 	

I should note that by becoming "sluggish" I mean that Firefox is becoming
sluggish at entering text and it takes a long time with long delays for the
individual chracters to appear after the keyboard keys are pressed in
succession.

Can someone look into this bug already?

-------- Comment #4 From Shlomi Fish on 2010-03-28 21:35:16 CEST (-) [reply] -------- 	

OK(In reply to comment #3)
> I should note that by becoming "sluggish" I mean that Firefox is becoming
> sluggish at entering text and it takes a long time with long delays for the
> individual chracters to appear after the keyboard keys are pressed in
> succession.
> 
> Can someone look into this bug already?

Replying to myself I should note that I was able to reproduce this bug on my
Debian Testing (Squeeze) partition with the vanilla firefox. So I guess it is
global to Firefox. I'll report it on http://bugzilla.mozilla.org/ .

Sorry for not checking earlier.

-------- Comment #5 From Shlomi Fish on 2010-03-28 22:20:57 CEST (-) [reply] -------- 	

I just discovered this earlier bug report also by me:

https://bugzilla.mozilla.org/show_bug.cgi?id=536880

I couldn't find any other duplicates.
Comment 2 Shlomi Fish 2010-03-28 13:27:18 PDT
And someone should triage this bug already.
Comment 3 Tomer Cohen :tomer 2010-03-28 13:33:15 PDT
Can you please link to a MediaWiki installation with no requirement to login in order to edit pages?
Comment 4 Shlomi Fish 2010-03-29 00:39:16 PDT
(In reply to comment #3)
> Can you please link to a MediaWiki installation with no requirement to login in
> order to edit pages?

Here you go:

http://en.wikipedia.org/wiki/User:Shlomif/Firefox_Test

I should note that I gave you an authentication for http://en.wikibooks.org/wiki/User:Shlomif-kdetest in the previous comment and that I cannot seem to reproduce this problem without being logged in.

Regards,

-- Shlomi Fish
Comment 5 Shlomi Fish 2010-06-16 05:16:55 PDT
Hi all!

I filed this bug many months ago, and it wasn't dealt with? Why hasn't anyone looked into it yet? The ball is in your court. I will write a periodic reminder comment for this bug here to remind you about it. I guess that "Out of sight - out of mind.". Sigh.

Regards,

-- Shlomi Fish
Comment 6 xaliqen 2010-09-15 00:52:19 PDT
I experience the same issue editing pages on en.wikipedia.org.

Here's my current info:

Mozilla/5.0 (X11; Linux x86_64; rv:2.0b7pre) Gecko/20100914 Firefox-4.0/4.0b7pre Ubuntu/10.10
Comment 7 Nickolay_Ponomarev 2010-09-29 14:52:31 PDT
I can't reproduce by editing a bit with http://en.wikipedia.org/wiki/User:Shlomif/Firefox_Test while logged in using my own account or on http://en.wikibooks.org/wiki/User:Shlomif-kdetest using the provided test account with Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:2.0b7pre) Gecko/20100926 Firefox/4.0b7pre.

This means this is Linux-specific or that the steps to reproduce aren't clear enough. This bug would benefit from profiling, but I don't know what's needed to do that on Linux.

Note also bug 376359.
Comment 8 astrea.do 2010-12-27 12:34:15 PST
same thing here since i'm using FF4 nightlies (4.0b9pre 12-27) and ubuntu 10.10. just a bit faster in safe mode but still slow when editing any wiki page
Comment 9 Wayne Mery (:wsmwk, NI for questions) 2011-09-20 13:37:00 PDT
astrea, Shlomi, ...
Do you still see this with version 6 or 7?
does bug 376359 reproduce for you (cited in comment 7)


comment 0 is similar to what I have just reported in bug 687978. however, I don't see delays with current trunk build on vista when using http://wiki.osdc.org.il/index.php?title=User:Shlomif/Firefox_Test_Page_No._1&action=edit
Comment 10 Shlomi Fish 2011-09-27 06:57:11 PDT
Hi Wayne,

(In reply to Wayne Mery (:wsmwk) from comment #9)
> astrea, Shlomi, ...
> Do you still see this with version 6 or 7?

I can no longer reproduce this with version 6. (Fresh profile, Firefox 6.0.2 from mozilla.org on an x86-64 machine).

> does bug 376359 reproduce for you (cited in comment 7)
> 

It seems to be OK here (with the Mandriva-supplied x86-64 firefox and my default, populated, profile).

> 
> comment 0 is similar to what I have just reported in bug 687978. however, I
> don't see delays with current trunk build on vista when using
> http://wiki.osdc.org.il/index.php?title=User:Shlomif/Firefox_Test_Page_No.
> _1&action=edit
Comment 11 Tomer Cohen :tomer 2011-09-27 07:00:28 PDT
Hi Amir,

Since you are mapping almost every MediaWiki+RTL issue across every browser, do you have any clue what caused this issue? 

Thanks.
Comment 12 Wayne Mery (:wsmwk, NI for questions) 2012-08-27 14:16:54 PDT
WFM per comment 10. ANd my own testing.

Note You need to log in before you can comment on or make changes to this bug.