If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Content of Search field not removed when changing folder

RESOLVED DUPLICATE of bug 517202

Status

Thunderbird
Search
RESOLVED DUPLICATE of bug 517202
8 years ago
7 years ago

People

(Reporter: Ingo Fischer, Unassigned)

Tracking

({regression})

x86
Windows XP
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.23) Gecko/20090812 Lightning/0.9 Thunderbird/2.0.0.23 Mnenhy/0.7.6.666

When you use the search-field to filter the messages in the current folder then in TB2 the content of the search-filed was emptied/removed when you changed the folder.
In TB3 the content of the search-field will stay and so it's confusing because in the new folder no messages are filtered, but there is a value in the search-field.

Reproducible: Always

Steps to Reproduce:
1. prepare two folders with messages, configure the search-field for your folders to filter the messages
2. enter text in the search-field and your messages are filtered (you only see the messages that match your text)
3. change to another folder
Actual Results:  
The new folder is displayed completely, but the search-field still contains the text from before. The problem is that this behaviour is confusing becvause in the newly choosed folder no messages are filtered, but there is a value in the search-field.

Expected Results:  
Do it as in TB2 - remove/empty the content of the search-field when folder is changed
Component: General → Search
Keywords: regression
QA Contact: general → search
Whiteboard: dupme
Version: unspecified → 3.0
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 517202
Cleanup *dupeme* whiteboard flag from bugs that are marked as Resolved
Duplicate!
Whiteboard: dupme
You need to log in before you can comment on or make changes to this bug.