Unable to log in and logs off automatically with Seamonkey on groupnet.greatwestlife.com

RESOLVED WORKSFORME

Status

()

Core
General
RESOLVED WORKSFORME
8 years ago
a year ago

People

(Reporter: william.tse.168, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needs reproducing with seamonkey, site requires login], URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.6) Gecko/20091206 SeaMonkey/2.0.1
Build Identifier: Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.6) Gecko/20091206 SeaMonkey/2.0.1

I just migrated from seamonkey verion 1.1.17 to version 2.0.1.  Previously I had no problem logging into this page and navigating after login.  Now, I have problems logging in.  Hard to explain why, but after several tries, I can get in but I try to navigate and I get logged off.  I can only think that it is a compatibility issue that is unique to seamonkey version 2.0.1 as I never had this problem before, not even with netscape 7.2 which was my previous browser.  Also, there are no compatiblity issues with firefox 3.5.6.

Reproducible: Sometimes

Steps to Reproduce:
1. Cannot log in
2. Repeat attempts result in successful login
3. Navigating anywhere right after login results in logoff and redirect back to login page
Actual Results:  
see above

Expected Results:  
I expect seamonkey 2.0.1 to work as this problem has never occurred with past mozilla based browsers.

Comment 1

8 years ago
Seamonkey uses a very similar, if not identical, engine (Gecko), so this is most likely a problem with the site sniffing the user agent or with your local configuration.

To test if the problem is user-agent related, try changing your UA string to Firefox's and see if the problem goes away.

Try using Seamonkey and Firefox on a different machine to see if it's a problem with local configuration.
Summary: Compatibility issues with using noted web page → Unable to log in and logs off automatically with Seamonkey on groupnet.greatwestlife.com
Whiteboard: [needs reproducing with seamonkey, site requires login]
(In reply to comment #0)
> Steps to Reproduce:
> 1. Cannot log in
> 2. Repeat attempts result in successful login
> 3. Navigating anywhere right after login results in logoff and redirect back to

Did you type correct password again? Or you always used autofilled password by password manager?

This kind of site usually uses cookie to keep "session"(term of server side application. similar but absolutely different concept from "session" at browser), and cookie is used to keep/control session-id and the session.
Does problem occur even after clearng of cookies for the site? (i.e. force server side application to discard old session-id, to start new session, to use new session-id).

Comment 3

5 years ago
(In reply to WADA from comment #2)
> (In reply to comment #0)
> > Steps to Reproduce:
> > 1. Cannot log in
> > 2. Repeat attempts result in successful login
> > 3. Navigating anywhere right after login results in logoff and redirect back to
> 
> Did you type correct password again? Or you always used autofilled password
> by password manager?
> 
> This kind of site usually uses cookie to keep "session"(term of server side
> application. similar but absolutely different concept from "session" at
> browser), and cookie is used to keep/control session-id and the session.
> Does problem occur even after clearng of cookies for the site? (i.e. force
> server side application to discard old session-id, to start new session, to
> use new session-id).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(william.tse.168)
Resolution: --- → INCOMPLETE
(Reporter)

Updated

5 years ago
Resolution: INCOMPLETE → WORKSFORME

Updated

a year ago
Flags: needinfo?(william.tse.168)
You need to log in before you can comment on or make changes to this bug.