periodic tasks show up before their start date

RESOLVED DUPLICATE of bug 373775

Status

RESOLVED DUPLICATE of bug 373775
9 years ago
9 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

Lightning 0.9
x86
Linux

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.16) Gecko/2009121601 Ubuntu/9.04 (jaunty) Firefox/3.0.16
Build Identifier: periodic tasks show up before their start date

Periodic tasks show up in incomplete list even before their start date. This should not be the case, or else they would always show up, even when completed for this period (... because it would still be incomplete for _next_ period...)


Reproducible: Always

Steps to Reproduce:
1. Set up a periodic task (start 1st of month, due 4th of month)


Actual Results:  
Task shows up even if not within the specified window

Expected Results:  
Periodic task should only show up in incomplete if both following conditions are met:
1. Beyond start date for this period
2. Not yet completed for this period

Example:

It's December 28th. Task should only show up if not completed for December. On January 1st, it should pop up again, and then go away if completed for January (and re-appear on February 1st...)
Component: General → Tasks
QA Contact: general → tasks
Summary: version 2.0.0.23 (20090817) → periodic tasks show up before their start date
Version: unspecified → Lightning 0.9
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 373775
You need to log in before you can comment on or make changes to this bug.