If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

xp filepicker not opening because content/global/filepicker.css not in jar.mn

VERIFIED FIXED

Status

()

Core
XUL
P2
blocker
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: Peter ``jag'' Annema, Assigned: Brian Ryner (not reading))

Tracking

({regression})

Trunk
x86
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rtm++] checked in on trunk)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
This entry seems to be missing from xpfe/components/jar.mn, and prevents the xp
filepicker from displaying on jar builds.
(Reporter)

Comment 1

17 years ago
Tweaking summary, keyword magic, accepting bug, simple fix, needed for nsbeta3,
will block Browser QA test B3, attaching patch.
Severity: normal → blocker
Status: NEW → ASSIGNED
Keywords: nsbeta3, patch, review
Summary: content/global/filepicker.css not in jar.mn → xp filepicker not opening because content/global/filepicker.css not in jar.mn
(Reporter)

Comment 2

17 years ago
Created attachment 15304 [details] [diff] [review]
[patch] add content/global/filepicker.css to jar.mn

Comment 3

17 years ago
r=axel@pike.org

The ">" icons are really misleading, though the missing css doesn't keep the 
filepicker from starting. It's just bad UI.

Axel
(Reporter)

Comment 4

17 years ago
Hmmm, this is nice...

When using jar files, missing css files fail silently, the filepicker loads, but
with triangles instead of folder icons.

When not using jar files, it doesn't load.

I'll see if there's a bug on that. Anyway, now I just need a= :-)
Keywords: review → approval
(Reporter)

Comment 5

17 years ago
r=/a=ben, and checked in, marking fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

17 years ago
Reopening so we can try to land this on the branch
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Updated

17 years ago
Assignee: disttsc → bryner
Status: REOPENED → NEW
Keywords: approval → correctness, rtm
Whiteboard: checked in on trunk
(Reporter)

Comment 7

17 years ago
Assigning to bryner, who's volunteered lobbying to get this checked in on the
branch.
(Assignee)

Comment 8

17 years ago
Addding regression kw.

This worked up until the landing of JAR files, when someone apparently forgot to
add filepicker.css to the jar.mn.  Right now, since we fail to load that file,
directories get the regular tree twisty icon instead of the folder icon.  This
would be confusing for the user because these "twisties" CAN NOT be expanded as
the icon would suggest.  This is an extremely low-risk, trivial fix and I think
we should get it in for RTM.
Status: NEW → ASSIGNED
Keywords: regression

Comment 9

17 years ago
rtm+ need info.  Ben needs to indicate his a= approval in this bug report before
we can change to rtm+
Priority: P3 → P2
Whiteboard: checked in on trunk → [rtm+ need info] checked in on trunk
Target Milestone: --- → M19
r=ben.

waterson said he'd provide a= pending this review. 
(Assignee)

Comment 11

17 years ago
changing to rtm+ per ben's a=.
Whiteboard: [rtm+ need info] checked in on trunk → [rtm+] checked in on trunk

Comment 12

17 years ago
PDT marking [rtm++]
Whiteboard: [rtm+] checked in on trunk → [rtm++] checked in on trunk
(Assignee)

Comment 13

17 years ago
checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 14

17 years ago
verified fixed, trunk and branch.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.