Closed Bug 536972 Opened 10 years ago Closed 10 years ago

Cannot uninstall Fennec from Settings -> Memory Settings/Remove Programs

Categories

(Firefox for Android Graveyard :: General, defect, blocker)

Fennec 1.1
ARM
Windows Mobile 6 Professional
defect
Not set
blocker

Tracking

(status1.9.2 .2-fixed)

VERIFIED FIXED
Tracking Status
status1.9.2 --- .2-fixed

People

(Reporter: aakashd, Assigned: alexp)

References

Details

(Keywords: relnote, verified1.9.2)

Attachments

(2 files, 4 obsolete files)

Build Id:

Mozilla/5.0 (Windows; U; WindowsCE 5.2; en-US; rv:1.9.2b6pre) Gecko/20091228 Namoroka/3.6b6pre Fennec/1.0a4pre



Steps to Reproduce:
1. Have Fennec installed on your device. I had the build from 12/23 on my device.
2. Go to the latest-mobile-1.9.2 nightly builds folder
3. Save and Run the installation exe for 12/28's nightly build
4. Reboot the device
5. Try to uninstall via both methods (delete folder and memory settings -> main storage)

Actual Results:
When trying to delete the folder, I receive the error "The process cannot access the file because it is being used by another process"

Fennec is not seen on Memory Settings -> Main Storage

Expected Results:
Fennec should be able to be deleted, especially after restart.
Since we don't have .cab files, its not listed on Memory Settings -> Main Storage. We need to relnote this since its a change in user experience from previous versions.
Keywords: relnote
Summary: Omnia 2:Cannot uninstall fennec → Omnia 2: Cannot uninstall fennec
Alex, I think we can just install a dummy .cab at some point during our .exe install that has an uninstall script to call uninstall.exe.  Make sense?
Assignee: nobody → alexp
Summary: Omnia 2: Cannot uninstall fennec → Omnia 2: Cannot uninstall fennec from Settings -> Memory Settings
(In reply to comment #0)

> 5. Try to uninstall via both methods (delete folder and memory settings -> main
> storage)

just a note for clarity, deleting the fennec folder is not the same as uninstalling it and will never work while fast start is enabled.
(In reply to comment #2)
> Alex, I think we can just install a dummy .cab at some point during our .exe
> install that has an uninstall script to call uninstall.exe.  Make sense?

It was an original idea for a bug 502933 fix. There were some issues with this approach. But I will probably have another look at this some time later.
Until this issue is resolved properly we should mention somewhere in the documentation that Fennec can be uninstalled by running uninstall.exe located in the Fennec folder.

As there is a way to uninstall the application correctly, I don't think this bug is a blocker.
Depends on: 541571
Summary: Omnia 2: Cannot uninstall fennec from Settings -> Memory Settings → Cannot uninstall Fennec from Settings -> Memory Settings/Remove Programs
Attached patch Patch (obsolete) — Splinter Review
Setup.dll for the additional CAB, which is installed by the main Fennec installer.
This adds Fennec to the system list of installed applications available in Settings - System - Remove Programs.
When removed from there the Setup.dll launches Uninstall.exe, which does the job.
Attachment #425062 - Flags: review?(bugmail)
Attached patch Patch mobile (obsolete) — Splinter Review
Makefile change to create the additional CAB.
Has to land together with the main patch.
Attachment #425065 - Flags: review?(bugmail)
Comment on attachment 425062 [details] [diff] [review]
Patch

>--- /dev/null
>+++ b/build/package/wince/make_winmo_cab.py
let's not create a new file.  just modify make_wince_cab.py

>+// The registry key is hardcoded as Setup.dll has to know it
>+// without reading any extra files
>+const WCHAR c_sAppRegKey[] = L"Software\\Mozilla\\Fennec";
don't hard code the app name, you should be able to get it at build time (or post process in mobile-browser)

>+// To continue installation, return codeINSTALL_INIT_CONTINUE
>+// If you want to cancel installation, return codeINSTALL_EXIT_UNINSTALL
drop this comment and others like it, they look like boiler plate
>+const WCHAR c_sAppRegKey[] = L"Software\\Mozilla\\Fennec";
>+
again, don't hard code
Attachment #425062 - Flags: review?(bugmail) → review-
Comment on attachment 425065 [details] [diff] [review]
Patch mobile

clearing the review because I'm assuming this will need to change a bit.
Attachment #425065 - Flags: review?(bugmail)
(In reply to comment #8)
> >+// The registry key is hardcoded as Setup.dll has to know it
> >+// without reading any extra files
> >+const WCHAR c_sAppRegKey[] = L"Software\\Mozilla\\Fennec";
> don't hard code the app name, you should be able to get it at build time (or
> post process in mobile-browser)

As it's in xulrunner, we don't have the actual name at build time.
Setup.dll does not interact with the EXE uninstaller, and doesn't have access to any strings .ini files where it could get the name.
This registry key is just to store the installation path. It is not visible in the UI, so I believe its name is not very important.

Besides we use "fennec" internally anyway, it seems "mozilla/fennec" is the path for the profile on Maemo.
Attached patch Patch v2 (obsolete) — Splinter Review
Code review changes.
Attachment #425062 - Attachment is obsolete: true
Attachment #425366 - Flags: review?(bugmail)
Attached patch Patch mobile v2 (obsolete) — Splinter Review
Moved Setup.dll to the mobile tree.
Attachment #425065 - Attachment is obsolete: true
Attachment #425368 - Flags: review?(bugmail)
Attachment #425366 - Flags: review?(bugmail) → review+
Comment on attachment 425368 [details] [diff] [review]
Patch mobile v2


>-DIRS       = chrome locales components themes app
>+DIRS       = chrome locales components themes app installer/wince

only add installer/wince to DIRS conditional on WINCE being defined 

r+ with that change
Attachment #425368 - Flags: review?(bugmail) → review+
Attached patch Patch mobile v3Splinter Review
Fixed Makefile.
Attachment #425368 - Attachment is obsolete: true
Attachment #425388 - Flags: review+
Attached patch Patch v3Splinter Review
Minor code review changes.

Please note - this patch has to be applied after bug 541571, as it changes the same parts of code.
Attachment #425366 - Attachment is obsolete: true
Attachment #425410 - Flags: review+
Keywords: checkin-needed
Aakash, can you verify this for 1.9.2 please and add the "verified1.9.2" keyword when you do?
verified FIXED on build:

Mozilla/5.0 (Windows; U; WindowsCE 5.2; en-US; rv:1.9.2.2pre) Gecko/20100226 Namoroka/3.6.2pre Fennec/1.1a1
Status: RESOLVED → VERIFIED
Keywords: verified1.9.2
what is the checkin-needed about?
I guess it's not needed anymore as the change is already pushed.
Keywords: checkin-needed
Component: Windows Mobile → General
OS: Windows Mobile 6 Standard → Windows Mobile 6 Professional
QA Contact: mobile-windows → general
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.