addon restart button closes fennec but doesn't restart it

VERIFIED WORKSFORME

Status

Fennec Graveyard
General
VERIFIED WORKSFORME
8 years ago
7 years ago

People

(Reporter: blassey, Assigned: Brian Crowder)

Tracking

Fennec 1.1
ARM
Windows Mobile 6 Professional
Bug Flags:
in-litmus +

Details

clicking the the addon restart button closes the fennec window but doesn't actually restart the browser
Flags: in-litmus?
(Assignee)

Comment 1

8 years ago
I cannot reproduce this, can you provide more detailed steps-to-reproduce?
wfm with the 1/8/10 nightly
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
I've seen this problem on RC2 over the weekend and nothing was fixed relating to the addons manager between RC 2 Build 2 and 1/8 nightly build
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Comment 4

8 years ago
Testing this with my own 1.9.2 build from 33503:05a4cc93f14b, I see the browser restart after pressing the "restart" button in the addons restart window.
(Assignee)

Comment 5

8 years ago
re: comment 3; the reason I was assigned this bug is that addons manager isn't the only possible culprit in breaking restart.  It is possible for a regression in any component that listens to quit-application notifications (and denies them) to cause addons restart to break.  One such component is my FastStartup.js code.  Still, I've never been able to reproduce this bug.
(Assignee)

Comment 6

8 years ago
Resolving this as incomplete until I get detailed steps-to-reproduce.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → INCOMPLETE
I'll do you one better and resolve works for me.  I stopped seeing this some time in the first week of january.
Resolution: INCOMPLETE → WORKSFORME
(Assignee)

Comment 8

8 years ago
It would be nice to know how this regressed and then how it was fixed.  Is this bug or something like it in litmus?
Yes, we have testcases in litmus for it:

https://litmus.mozilla.org/show_test.cgi?id=7133
https://litmus.mozilla.org/show_test.cgi?id=7304

nothing has shown up there.

verified WFM on builds:
Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2pre) Gecko/20100119 Firefox/3.6pre Fennec/1.1a1pre

and

Mozilla/5.0 (X11; U; Linux armv6l; Nokia N8xx; en-US; rv:1.9.3a1pre) Gecko/20100119 Firefox/3.7a1pre Fennec/1.1a1pre
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Windows Mobile → General
QA Contact: mobile-windows → general
Flags: in-litmus? → in-litmus+
You need to log in before you can comment on or make changes to this bug.