If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

allow to build sunbird as xulapp with libxul-sdk

RESOLVED WONTFIX

Status

Calendar
Build Config
RESOLVED WONTFIX
8 years ago
7 years ago

People

(Reporter: wolfiR, Assigned: wolfiR)

Tracking

Details

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
Sunbird build should support --with-libxul-sdk correctly.

Sunbird should be an easy target to be based on xulrunner as its components are using frozen api already. There are "only" build config changes needed to make that work apparently.
That's probably quite interesting for Linux distributions as they ship Firefox as xulapp based on xulrunner already (in most cases).
(Assignee)

Comment 1

8 years ago
Created attachment 420065 [details] [diff] [review]
patch

This patch fixes some stuff which is related with building --with-libxul-sdk and with that I was able to build and run Sunbird on top of xulrunner successfully.
(In reply to comment #1)
> Created an attachment (id=420065) [details]
> patch
> 
> This patch fixes some stuff which is related with building --with-libxul-sdk
> and with that I was able to build and run Sunbird on top of xulrunner
> successfully.

This will break packaging of branding on Mac. Anything that gets installed into $(DIST)/bin or underneath must happen before the "libs repackage:: $(PROGRAM)" step.
(Assignee)

Comment 3

8 years ago
(In reply to comment #2)
> This will break packaging of branding on Mac. Anything that gets installed into
> $(DIST)/bin or underneath must happen before the "libs repackage:: $(PROGRAM)"
> step.

The libs repackage step is non-libxul-sdk only. I can test my changes only on Linux.
If you tell me exactly what part of my changes is breaking it I probably can think about it (w/o being able to test though).
Only the icon export step is affected AFAICS, right?
Assignee: nobody → mozilla
Status: NEW → ASSIGNED
Comment on attachment 420065 [details] [diff] [review]
patch

The problem is moving this part:

>-ifneq (,$(filter gtk gtk2,$(MOZ_WIDGET_TOOLKIT)))
>-ICON_FILES = \
>-    $(DIST)/branding/mozicon128.png \
>-    $(DIST)/branding/mozicon50.xpm \
...
...
...
>-ifeq ($(MOZ_WIDGET_TOOLKIT),gtk2)
>-	cp $(srcdir)/default.xpm  $(DIST)/branding/default.xpm
>-endif
>-ifeq ($(OS_ARCH),OS2)
>-	cp $(srcdir)/sunbird-os2.ico  $(DIST)/branding/sunbird.ico
>-endif
>-endif
>
below:


libs repackage:: $(PROGRAM)
	mkdir -p $(DIST)/$(APP_NAME).app/Contents/MacOS
	rsync -a --exclude CVS --exclude "*.in" $(srcdir)/macbuild/Contents $(DIST)/$(APP_NAME).app  --exclude English.lproj
	mkdir -p $(DIST)/$(APP_NAME).app/Contents/Resources/$(AB).lproj
...
	printf APPL$(MAC_CREATOR_CODE) > $(DIST)/$(APP_NAME).app/Contents/PkgInfo
#	remove CVS dirs from packaged app
	find $(DIST)/$(APP_NAME).app -type d -name "CVS" -prune -exec rm -rf {} \;

that bit. The icons wouldn't get packaged on non-libxul Mac builds.
(Assignee)

Comment 5

8 years ago
Have you tested that? I think it would work because:

- the ICON_FILES stuff is gtk, gtk2 only
- the branding/icon related things are gtk2 only
- the icon stuff inbetween which affects mac/cocoa is in the export target and 
  that is done before libs, isn't it?
(Assignee)

Comment 6

7 years ago
Sunbird is dead apparently
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.