Logging into forums.addons.mozilla.org is unnecessary hard when you already have an account on AMO (requires AMO Nickname)

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Forums
P3
normal
RESOLVED WONTFIX
8 years ago
2 years ago

People

(Reporter: Nickolay_Ponomarev, Unassigned)

Tracking

unspecified
4.x (triaged)

Details

(Whiteboard: [clint eastwood][lang=php])

(Reporter)

Description

8 years ago
When you try to login to the forums, even when logged into main AMO already, it asks you to log in, but asks for something called "AMO Nickname" as login.

Steps to reproduce:
1. https://forums.addons.mozilla.org/ucp.php?mode=login
2. try to enter your email (-> invalid login/password)
3. try the forget password link (-> sends email, which makes you change the main AMO password, but doesn't help with figuring out what an "AMO Nickname" is)
4. Try the register link (-> takes you to https://addons.mozilla.org/en-US/firefox/ and says "Welcome, Nickolay" at the top. Hello there!)
5. Finally figure out to go to the https://addons.mozilla.org/en-US/firefox/users/edit find the "Nickname" field there and try that as the login.

Actual results: succeeded on step 5.

Expected results: succeed on step 2 or at least give an actual explanation that would allow me to skip to step 5.
(Reporter)

Comment 1

8 years ago
It appears to have already been brought up: https://forums.addons.mozilla.org/viewtopic.php?f=26&t=19
Summary: Logging into forums.addons.mozilla.org is unnecessary hard when you already have an account on AMO → Logging into forums.addons.mozilla.org is unnecessary hard when you already have an account on AMO (requires AMO Nickname)
Priority: -- → P3
Target Milestone: --- → 4.x (triaged)

Updated

8 years ago
Whiteboard: [SSO]
The goal here is to write a phpBB plugin that will talk to browserid/persona and people will be able to log in with that.  At that point the forum authentication will be decoupled from AMO completely.

If anyone has the ability and time to write that phpBB plugin, let me know.
Whiteboard: [SSO] → [clint eastwood][lang=php]
Thanks for filing this.  Due to resource constraints we are closing bugs which we won't realistically be able to fix.  If you have a patch that applies to this bug please reopen.

For more info see http://micropipes.com/blog/2014/09/24/the-great-add-on-bug-triage/
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.