Can not have more than one name/email filer in the same message filter

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
9 years ago
9 years ago

People

(Reporter: ldk1785, Unassigned)

Tracking

1.9.1 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2010-02-20)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091204 Thunderbird/3.0

1. Unable to put more than 1 email/name in the same message filter. If someone has more than 1 email address you have to have a separate filter or each one. If you have two or more in the same filter only the first one in the list is used the rest are ignored.

2. Put the choice of the total, read numbers in the folders list. As it is now Ver 3.0) it only shows whe you have a new email in the folder. Once read you have no idea how many emails are in the folder.

Reproducible: Always

Steps to Reproduce:
1. get an email from the same person/org
2. try to set a message filter wit more than one filter selection
3.
Actual Results:  
See details & steps to reproduce

Expected Results:  
See details & steps to reproduce

Basic Thunderbird installed with no added items.

Comment 1

9 years ago
Re 1:

What can't you just create multiple search lines, use "Match any of the following", and include each address as a separate search term? I do that.

Re 2:

This is an unrelated request, and should be in a different bug. But the bottom line is that this functionality is now in the extension https://addons.mozilla.org/en-US/thunderbird/addon/9716 and is unlikely to be added back to the core code.

Updated

9 years ago
Component: General → Filters
Product: Thunderbird → MailNews Core
QA Contact: general → filters
Version: unspecified → 1.9.1 Branch

Comment 2

9 years ago
Larry, please give an example (the entire filter definition) of #1 failing using v3.0.1
Severity: major → normal
Summary: Message filter BUG. Can not have more than one name/email filer in the same message filter → Can not have more than one name/email filer in the same message filter
Whiteboard: closeme 2010-02-20
RESOLVED INCOMPLETE due to lack of response to last question. If you feel this change was made in error, please respond with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.