Closed Bug 537032 Opened 11 years ago Closed 11 years ago

[OS X 64-bit] css gradients are not painted

Categories

(Core :: Web Painting, defect)

x86_64
macOS
defect
Not set
normal

Tracking

()

VERIFIED FIXED

People

(Reporter: phiw2, Assigned: BenWa)

References

Details

Attachments

(3 files)

When Minefield is build in 64-bit mode, CSS gradients are not painted. The background is transparent instead.

This is also visible in chrome (e.g. the buttons at the top of the add-ons window)
Attached file html test case
There should be a yellow-to-blue diagonal gradient in the box.
Hardware: x86 → x86_64
Assignee: nobody → joshmoz
Assignee: joshmoz → nobody
This is caused by using floats instead of CGFloats. CGFloat is double on 64bit. Ben is going to come up with a patch.
Comment on attachment 421650 [details] [diff] [review]
Replace float pointer types with CGFloat. CoreGraphics uses CGFloat which are float for 32-bits and double for 64-bits.

Looks good.
Attachment #421650 - Flags: review?(jmuizelaar) → review+
Assignee: nobody → bgirard
Attachment #421650 - Flags: review+
http://hg.mozilla.org/mozilla-central/rev/f85c8c1c111e
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Works fine with a build @ http://hg.mozilla.org/mozilla-central/rev/32b8675c4a23.

Thanks
Status: RESOLVED → VERIFIED
Component: Layout: View Rendering → Layout: Web Painting
You need to log in before you can comment on or make changes to this bug.