Firefox 3.6 FPU exception Crashes [@ js_Interpret:916 ] [@ js_Interpret:904 ]

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: chofmann, Unassigned)

Tracking

({crash, regression})

Trunk
x86
Windows XP
crash, regression
Points:
---
Dependency tree / graph
Bug Flags:
wanted1.9.2 ?

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [crashkill], crash signature)

(Reporter)

Description

9 years ago
after the skip list  js_Interpret crashes this one appears to be the most frequent.

Firefox 3.6b5 Crash Report [@ js_Interpret:916 ]

stack looks like

http://crash-stats.mozilla.com/report/index/dea15c65-fffb-4445-be93-abdb72091228

Frame  	Module  	Signature [Expand]  	Source
0 	js3250.dll 	js_Interpret 	js/src/jsops.cpp:916
1 	js3250.dll 	js_Invoke 	js/src/jsinterp.cpp:1369
2 	js3250.dll 	js_fun_apply 	js/src/jsfun.cpp:2046
3 	js3250.dll 	js_Interpret 	js/src/jsops.cpp:2208
4 	js3250.dll 	js_Invoke 	js/src/jsinterp.cpp:1369
5 	js3250.dll 	js_fun_call 	js/src/jsfun.cpp:1955
6 	js3250.dll 	js_Interpret 	js/src/jsops.cpp:2208
7 	js3250.dll 	js_Invoke 	js/src/jsinterp.cpp:1369
8 	js3250.dll 	js_InternalInvoke 	js/src/jsinterp.cpp:1424
9 	js3250.dll 	JS_CallFunctionValue 	js/src/jsapi.cpp:5103
10 	xul.dll 	nsJSContext::CallEventHandler 	dom/base/nsJSEnvironment.cpp:2134
11 	xul.dll 	nsJSEventListener::HandleEvent 	dom/src/events/nsJSEventListener.cpp:266
12 	xul.dll 	nsEventListenerManager::HandleEventSubType 	content/events/src/nsEventListenerManager.cpp:1041
13 	xul.dll 	nsEventListenerManager::HandleEvent 	content/events/src/nsEventListenerManager.cpp:1147
14 	xul.dll 	nsEventTargetChainItem::HandleEventTargetChain 	content/events/src/nsEventDispatcher.cpp:310
15 	xul.dll 	nsEventDispatcher::Dispatch 	content/events/src/nsEventDispatcher.cpp:573
16 	xul.dll 	PresShell::HandleEventInternal 	layout/base/nsPresShell.cpp:6484
17 	xul.dll 	PresShell::HandleEventWithTarget 	layout/base/nsPresShell.cpp:6347
18 	xul.dll 	nsEventStateManager::CheckForAndDispatchClick 	content/events/src/nsEventStateManager.cpp:3983
19 	xul.dll 	nsLayoutUtils::TranslateWidgetToView 	layout/base/nsLayoutUtils.cpp:875


more at http://crash-stats.mozilla.com/report/list?range_value=2&range_unit=weeks&signature=js_Interpret%3A916&version=Firefox%3A3.6b5

seem to fluctuate between 30-119 crashes per day since dec 2. and exclusively a 3.6 problem.

checking --- 20091227-crashdata.csv js_Interpret:916
release total-crashes
              js_Interpret:916 crashes
                         pct.
all     207108  61      0.000294532
3.0.15  2940            0
3.0.16  32075           0
3.5.5   8122            0
3.5.6   110490          0
3.6b5   20527   42      0.00204609
3.6b4   2074    11      0.00530376
3.6b3   628             0
3.6b2   634     3       0.00473186
3.6b1   1937    5       0.00258131

A lot of the problem seems to be on facebook.

domains of sites
  48 http://www.facebook.com
   3 \N//
   2 http://upload.facebook.com
   2 http://apps.facebook.com
   1 https://login.yahoo.com
   1 http://www.keen.com
   1 http://1.channel45.facebook.com
   1 http://0.channel61.facebook.com
   1 http://0.channel23.facebook.com

os breakdown
32      0.52459 Windows NT5.1.2600 Service Pack 2
14      0.229508        Windows NT6.0.6002 Service Pack 2
7       0.114754        Windows NT5.1.2600 Service Pack 3
5       0.0819672       Windows NT6.1.7600
3       0.0491803       Windows NT6.0.6001 Service Pack 1
Flags: wanted1.9.2?
(Reporter)

Updated

9 years ago
Blocks: 528734
I just noticed that these are all EXCEPTION_FLT_INVALID_OPERATION, so it's probably a dup of bug 533035. We should recheck when a beta with the patch for that bug goes out.
Depends on: 533035
(Reporter)

Updated

9 years ago
Depends on: 538642
(Reporter)

Comment 2

9 years ago
guessing the signature [@ js_Interpret:904 ]  will also go away when the fix for Bug 538642 gets shipped in firefox 3.6.x

right now that's get 200+ (mostly facebook) crashes per day.


Frame  	Module  	Signature [Expand]  	Source
0 	js3250.dll 	js_Interpret 	js/src/jsops.cpp:904
1 	js3250.dll 	js_Invoke 	js/src/jsinterp.cpp:1368
2 	js3250.dll 	js_fun_apply 	js/src/jsfun.cpp:2046
3 	js3250.dll 	js_Interpret 	js/src/jsops.cpp:2208
4 	js3250.dll 	js_Invoke 	js/src/jsinterp.cpp:1368
5 	js3250.dll 	js_fun_apply 	js/src/jsfun.cpp:2046
6 	js3250.dll 	js_Interpret 	js/src/jsops.cpp:2208
7 	js3250.dll 	js_Invoke 	js/src/jsinterp.cpp:1368
8 	js3250.dll 	js_InternalInvoke 	js/src/jsinterp.cpp:1423
9 	js3250.dll 	JS_CallFunctionValue 	js/src/jsapi.cpp:5112
10 	xul.dll 	nsJSContext::CallEventHandler 	dom/base/nsJSEnvironment.cpp:2134
11 	xul.dll 	nsGlobalWindow::RunTimeout 	dom/base/nsGlobalWindow.cpp:8075
12 	xul.dll 	nsGlobalWindow::TimerCallback 	dom/base/nsGlobalWindow.cpp:8409
13 	xul.dll 	nsTimerImpl::Fire 	xpcom/threads/nsTimerImpl.cpp:427
14 	nspr4.dll 	_PR_MD_UNLOCK 	nsprpub/pr/src/md/windows/w95cv.c:344
15 	xul.dll 	nsTimerEvent::Run 	xpcom/threads/nsTimerImpl.cpp:519
16 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:527
17 	xul.dll 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:170
18 	xul.dll 	nsAppStartup::Run 	toolkit/components/startup/src/nsAppStartup.cpp:182
19 	nspr4.dll 	PR_GetEnv 	
20 	firefox.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp:120
21 	firefox.exe 	__tmainCRTStartup 	obj-firefox/memory/jemalloc/crtsrc/crtexe.c:591
22 	kernel32.dll 	BaseProcessStart 	 


2010 02 08
crash-count domains of sites
 195 http://www.facebook.com
  15 http://apps.facebook.com
   2 https://login.yahoo.com
   2 http://upload.facebook.com
   2 http://0.channel68.facebook.com
   1 https://login.facebook.com
   1 http://tr-tr.facebook.com
   1 http://id-id.facebook.com
   1 http://2.channel74.facebook.com
   1 http://1.channel48.facebook.com
   1 http://1.channel41.facebook.com
   1 http://1.channel24.facebook.com
   1 http://1.channel18.facebook.com
   1 http://0.channel54.facebook.com
   1 http://0.channel40.facebook.com
   1 http://0.channel24.facebook.com
   1 http://0.channel22.facebook.com
   1 http://0.channel15.facebook.com
   1 http://0.channel02.facebook.com
   1 http://0.channel01.facebook.com
Summary: Firefox 3.6b5 Crash Report [@ js_Interpret:916 ] → Firefox 3.6b5 Crash Report [@ js_Interpret:916 ] [@ js_Interpret:904 ]
(Reporter)

Comment 3

9 years ago
there are a couple js_Interpret:916 and 904 crashes, but volume appears to be way down on these two signatures with all the dependency bugs taking hold in firefox 3.6.2

http://crash-stats.mozilla.com/query/query?product=Firefox&version=Firefox%3A3.6.2&date=&range_value=1&range_unit=weeks&query_search=signature&query_type=contains&query=js_Interpret%3A9&build_id=&process_type=all&do_query=1

we should keep an eye on this for another day or two to get some more 3.6.2 crash data then probably close out.

Comment 4

9 years ago
The crashes in #3 are not FPU exceptions, so they are not covered by this patch.
We need a new bug (one will do for now) for the two crashes linked to in comment 3 -- both in RELATIONAL_OP macro calls, with bad addresses that are 0 mod 8. A GC safety bug, perhaps related to coming off trace, could be the cause.

/be
(Reporter)

Comment 6

9 years ago
(In reply to comment #5)
> We need a new bug (one will do for now) for the two crashes linked to in
> comment 3 -- both in RELATIONAL_OP macro calls, with bad addresses that are 0
> mod 8. A GC safety bug, perhaps related to coming off trace, could be the
> cause.
> 
> /be

Filed Bug 554401
(Reporter)

Updated

9 years ago
Summary: Firefox 3.6b5 Crash Report [@ js_Interpret:916 ] [@ js_Interpret:904 ] → Firefox 3.6 FPU exception Crashes [@ js_Interpret:916 ] [@ js_Interpret:904 ]
Crash Signature: [@ js_Interpret:916 ] [@ js_Interpret:904 ]

Comment 7

7 years ago
Nothing in any recent version beyond 3.6. Resolving as works for me.
Crash Signature: [@ js_Interpret:916 ] [@ js_Interpret:904 ] → [@ js_Interpret:916 ] [@ js_Interpret:904 ]

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.