Closed Bug 537061 Opened 10 years ago Closed 10 years ago

intermittent failure in browser_522545.js, "At least one tab has a userTypedValue with userTypedClear with no loaded URL"

Categories

(Firefox :: Session Restore, defect)

x86
All
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 3.7a4

People

(Reporter: karlt, Assigned: dao)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | userTypedClear=2 caused userTypedValue to be loaded - Got http://www.example.com/, expected http://example.com/
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | Address bar's value set after loading URI - Got http://www.example.com/, expected http://example.com/

WINNT 5.2 mozilla-central debug test everythingelse
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1262050816.1262057643.6065.gz

See also bug 528699.
OS: Linux → Windows Server 2003
Weird. It looks like http://example.com redirected to http://www.example.com, which shouldn't happen for mochitests.

I haven't seen this before but will mark as an orange in case others do.
Blocks: 438871
Whiteboard: [orange]
Not quite the same failure, but seems related

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1263521091.1263522678.26349.gz
Linux mozilla-central debug test mochitest-other on 2010/01/14 18:04:51  
s: moz2-linux-slave20
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | At least one tab has a userTypedValue with userTypedClear with no loaded URL
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1264035124.1264036544.16804.gz
Linux mozilla-central debug test mochitest-other on 2010/01/20 16:52:04

Looks the same as Chris's comment 2.
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1264096976.1264099021.10920.gz
Linux mozilla-central debug test mochitest-other on 2010/01/21 10:02:56
s: moz2-linux-slave28

TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | At least one tab has a userTypedValue with userTypedClear with no loaded URL
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1264185759.1264187187.29917.gz
Linux mozilla-central opt test mochitest-other on 2010/01/22 10:42:39
s: moz2-linux-slave21

TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | At least one tab has a userTypedValue with userTypedClear with no loaded URL
Linux mozilla-central debug, moz2-linux-slave25, http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1264334072.1264335624.24682.gz

TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | At least one tab has a userTypedValue with userTypedClear with no loaded URL
Looks like the failure in comment 0 didn't come back and this is now Linux only...
OS: Windows Server 2003 → Linux
Summary: intermittent failure in browser_522545.js → intermittent failure in browser_522545.js, "At least one tab has a userTypedValue with userTypedClear with no loaded URL"
Linux mozilla-central debug, moz2-linux-slave16, http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1264344826.1264346496.3240.gz
Linux mozilla-central debug, moz2-linux-slave28, http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1264412458.1264414562.1768.gz
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1264713189.1264717571.14392.gz
Linux mozilla-central debug test mochitest-other on 2010/01/28 13:13:09
s: moz2-linux-slave27
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1265105311.1265108459.12226.gz
Linux mozilla-central debug test mochitest-other on 2010/02/02 02:08:31
s: moz2-linux-slave28
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1265164906.1265169591.7206.gz
Linux mozilla-central debug test mochitest-other on 2010/02/02 18:41:46
s: moz2-linux-slave23
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1265488154.1265490495.23010.gz
Linux mozilla-central debug test mochitest-other on 2010/02/06 12:29:14
s: moz2-linux-slave28
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1265495291.1265496947.29724.gz
Linux mozilla-central debug test mochitest-other on 2010/02/06 14:28:11
s: moz2-linux-slave23
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1265557761.1265559477.18052.gz
Linux mozilla-central debug test mochitest-other on 2010/02/07 07:49:21
s: moz2-linux-slave18
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1265625687.1265627325.5217.gz
Linux mozilla-central debug test mochitest-other [testfailed] Started 02:41, finished 03:09
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1265868446.1265869199.1999.gz
Linux mozilla-central opt test mochitest-other on 2010/02/10 22:07:26
s: moz2-linux-slave05
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1265892056.1265893124.13802.gz
Linux mozilla-central opt test mochitest-other on 2010/02/11 04:40:56
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1266001548.1266003385.17804.gz
Linux mozilla-central opt test mochitest-other on 2010/02/12 11:05:48
s: moz2-linux-slave13
Linux mozilla-central opt test mochitest-other on 2010/02/16 07:45:53
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1266335153.1266335995.27835.gz
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1266534477.1266536586.9621.gz
Linux mozilla-central opt test mochitest-other on 2010/02/18 15:07:57
s: moz2-linux-slave06
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1266754298.1266755260.3348.gz
Linux mozilla-central opt test mochitest-other on 2010/02/21 04:11:38  
s: moz2-linux-slave41
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1267100611.1267102540.22299.gz
 Linux mozilla-central debug test mochitest-other on 2010/02/25 04:23:31
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1267564669.1267566070.14563.gz
Linux mozilla-central opt test mochitest-other on 2010/03/02 13:17:49
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1267677649.1267682092.15481.gz
Linux mozilla-central debug test mochitest-other on 2010/03/03 20:40:49  
s: moz2-linux-slave16
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1267724085.1267725534.20832.gz
Linux mozilla-central opt test mochitest-other on 2010/03/04 09:34:45
s: moz2-linux-slave06
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268187597.1268190056.13410.gz
Linux mozilla-central opt test mochitest-other on 2010/03/09 18:19:57
s: moz2-linux-slave05
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268616248.1268617851.22341.gz
Linux mozilla-central debug test mochitest-other on 2010/03/14 18:24:08
s: moz2-linux-slave19
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268656416.1268657964.4607.gz
Linux mozilla-central opt test mochitest-other on 2010/03/15 05:33:36
s: moz2-linux-slave05
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268677361.1268679316.6006.gz
Linux mozilla-central opt test mochitest-other on 2010/03/15 11:22:41
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268782211.1268783779.28575.gz
Linux mozilla-central debug test mochitest-other on 2010/03/16 16:30:11
s: moz2-linux-slave21
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268813791.1268816000.8869.gz
OS X 10.5.2 mozilla-central debug test mochitest-other on 2010/03/17 01:16:31
s: moz2-darwin9-slave14

Looks like this is no longer linux-only.
OS: Linux → All
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268814462.1268816480.10172.gz
OS X 10.5.2 mozilla-central debug test mochitest-other on 2010/03/17 01:27:42
s: bm-xserve17
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268812952.1268816408.9925.gz
Linux mozilla-central debug test mochitest-other on 2010/03/17 01:02:32
s: moz2-linux-slave24
http://hg.mozilla.org/mozilla-central/rev/16a974dd72e1
Assignee: nobody → dao
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.7a4
Alright, this didn't fix it. I'll keep investigating.

This seems to happen very frequently after bug 347930 landed, but I cannot reproduce locally.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
session store uses a setTimeout to restore these values, and uses a polling strategy in some case (restoreHistoryPrecursor for example).
I highly suspect that if you implement a polling strategy for userTypedValue this will be fixed.
Well, that sounds like it would make the test useless. The test is about a link between the load event and userTypedValue, i.e. it tests that if multiple tabs load and one finishes, "At least one tab has a userTypedValue with userTypedClear with no loaded URL". That doesn't seem to be a valid assumption at all. tabbrowser.xml clears userTypedValue in onLocationChange.
Oh, for the record, I disabled this part of the test for now:
http://hg.mozilla.org/mozilla-central/rev/a7b14b476e00
Attached patch patchSplinter Review
This way it would make sense, I think.
Attachment #433063 - Flags: review?(paul)
Comment on attachment 433063 [details] [diff] [review]
patch

I've pushed this to the try server, as I was seeing the failure there.
Comment on attachment 433063 [details] [diff] [review]
patch

Makes sense. I had been working under the assumption that doing this on the first load event was early enough since I was loading 25 tabs. Doing it on the first location change *should* make this better. So in theory we should be able to do less than 25 tabs now (not that it _really_ matters though). Thanks for looking into this.
Attachment #433063 - Flags: review?(paul) → review+
http://hg.mozilla.org/mozilla-central/rev/f3c18e250e3d
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
Flags: in-testsuite+
I cannot see this failure in the recent logs.  Marking VERIFIED.
Status: RESOLVED → VERIFIED
(In reply to comment #56)
This is new after <http://hg.mozilla.org/mozilla-central/rev/6a71deda9822>. Looks like the tests conflict. Not sure if it's intermittent.
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.