Recent versions of Firefox won't print secure pages to PDF

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: James Niss, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6

For years, I've been printing to PDF from secured Web pages (e.g., bank statements, boarding passes) with Firefox.  After some recent Firefox update, secured Web pages stopped printing to PDF from Firefox, although (1) unsecured pages print from Firefox to PDF, (2) secured pages print from Firefox to my printer, and (3) secured pages print to PDF from IE.  I have several PDF print drivers, and all of them fail to print secured Web pages from Firefox to PDF.

Reproducible: Always

Steps to Reproduce:
1.Open a secured Web page with Firefox
2.Click Print and select a PDF print driver 
3.Curse and stamp your feet


Expected Results:  
Either nothing happens, or Windows signals a print error
(Reporter)

Updated

9 years ago
OS: Mac OS X → Windows XP

Comment 1

9 years ago
works for me - Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a1pre) Gecko/20091228 Minefield/3.7a1pre and Adobe Distiller Pro 8.1.3
(Reporter)

Comment 2

9 years ago
In my report I attributed the problem to a recent Firefox update, but maybe somehow it was an XP update that broke Firefox but left IE working.  What I know is that the problem arose within about the past year.  My Firefox version is 3.5.6.

Comment 3

9 years ago
Also works fo rme on Linux: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2b6pre) Gecko/20091228 Namoroka/3.6b6pre
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID

Comment 4

9 years ago
You could try Firefox's basic troubleshooting document http://support.mozilla.com/en-US/kb/Basic+troubleshooting
You need to log in before you can comment on or make changes to this bug.