If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

opening a message in a tab shows the content of the last closed tab first

RESOLVED DUPLICATE of bug 535373

Status

Thunderbird
Toolbars and Tabs
--
major
RESOLVED DUPLICATE of bug 535373
8 years ago
7 years ago

People

(Reporter: bugzilla-user, Unassigned)

Tracking

x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.1.5) Gecko/20091204 Thunderbird/3.0

situation:
a message is opened in a tab. I close the tab. then i open a different message in a tab. the content of the formerly closed tab is shown in the new tab before the new messages appears.

Reproducible: Always

Steps to Reproduce:
1.open message in tab
2.close tab
3.open new message in tab


Expected Results:  
opening a message in a tab should just display the chosen message.
(Reporter)

Updated

8 years ago
Version: unspecified → 3.0

Comment 1

8 years ago
This might be related to bug 505446.

Comment 2

8 years ago
I see this all the time, not only in threaded msgs.  It sounds more like bug #518869 to me.

Comment 3

8 years ago
Does this make a link? 518869

Comment 4

8 years ago
I submitted a duplicate, bug 557578, and only just now found this bug report.  However, I feel the importance of the bug needs to be marked as "critical".

I've found that it is all to easy to read and then delete a message while Thunderbird is still displaying the wrong message (thus loss of data, making this a critical bug).  Say the first message opened was a automated job search notification providing a single link to a job posting that just isn't relevant to me.  It takes me maybe 1 second to read the posting title and hit delete.  When I read another job search notification later, the first message will show again for a few seconds.  It isn't particularly rare to receive duplicate postings through different services, and I have no reason to remember the exact title of job postings I don't care about...  So it only takes me maybe 1 second to read the old message again and decided to delete the new message.  The problem is, the new message may have contained any number of relevant job postings.

If Thunderbird goes crazy and deletes everything, then I can restore all my messages from my backups.  But this sort of bug is worse, as I won't always be aware of the data loss.
Duplicate of this bug: 557578
Looks like this is a duplicate of bug 535373 (although that bug adds a note about "no message pane" which might differentiate it). Anyone want to confirm that?
Severity: enhancement → major

Comment 7

7 years ago
(In reply to comment #1)
> This might be related to bug 505446.

Looks that way to me too.
Blocks: 535373
Depends on: 505446

Comment 8

7 years ago
(In reply to comment #6)
> Looks like this is a duplicate of bug 535373 (although that bug adds a note
> about "no message pane" which might differentiate it). Anyone want to confirm
> that?

Can you reproduce this one when the message pane is disabled?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 535373

Updated

7 years ago
No longer blocks: 535373
You need to log in before you can comment on or make changes to this bug.