Undoing IMAP message move then moving to new folder doesn't work

RESOLVED DUPLICATE of bug 533513

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 533513
8 years ago
8 years ago

People

(Reporter: Michael Baffoni, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091204 Thunderbird/3.0

1) Move message to folder A, message disappears from list
2) Undo Folder move, message reappears in original position
3) Move message to folder B, message disappears from list

Expected results:
4) Message should exist in Folder B.

Actual Resuslts
4) Message reappears at bottom of message list like a new message (sorted by order received), message is not in Folder B.  Moving newly appeared message at bottom of list results in moving the message to Folder B.

Although technically this is not dataloss, it could VERY easily lead to dataloss because people (like me) would typically see the message at the end of the list and think it was a duplicate and just delete it.  Also, very annoying that it then takes two moves to complete a single message move.
Is it the same message ?

Michael can you provide us with an imap log ?
(Reporter)

Comment 2

8 years ago
As far as I can tell it is the same message.  I'm in the middle of undoing a 170K message dupe on the IMAP folders (thank you TB2), I'll try and get this log today.

Comment 3

8 years ago
I can reproduce this. in fact, the message eventually reappears back in the original folder.

I suspect it's directly related to bug 533513
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 533513
You need to log in before you can comment on or make changes to this bug.