Table cell border not rendered if table has a double nested <tr> tag

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: Paolo Stefan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; it; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6 (.NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.30729; .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; it; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6 (.NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.30729; .NET CLR 3.5.30729)

If a table with CSS "border-collapse:collapse" has got a nested <tr> tag (see additional info), the borders of its cells are not rendered.

In IE8, the table cells are rendered correctly.

In "additional information", you find the html that breaks table rendering.

Reproducible: Always

Actual Results:  
Cells have no border.

Expected Results:  
Cells should have a border as specified in CSS rule "td".

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html><head><title></title>
<style type="text/css">
<!--
td {
	font-family: "Courier New", Courier, monospace;
	font-size: 11px;
	border:1px solid #bbb;
}
table {
	border: 1px solid #ccc;
	border-collapse:collapse;
}
-->
</style>
</head>
<body>
 text
<a href="http://localhost/tomas/bertos/ricambi/modTableAgg.php"></a><br>
<br>
<table cellspacing="0" cellpadding="0">
	<tr>
		<td>cell1</td>
		<td>cell2</td>
	</tr>
	<tr>
		<td>cell3</td>
		<td>cell4</td>
	</tr>
</table>
<p>text2<br> 
	The table below has a double nested &lt;tr&gt; (incorrect html):
</p>
<table cellspacing="0" cellpadding="0">
	<tr>
	<tr>
		<td>cell</td>
		<td>cell</td>
	</tr>
	
	<tr>
		<td>cell</td>
		<td>cell</td>
	</tr>
	</tr>
</table>
<p><br>
</p>
</body>
</html>

Comment 1

8 years ago
<tr><tr>
is shity coding, not a bug.
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> <tr><tr>
> is shity coding, not a bug.

I believe that a good browser (and Firefox is) should handle what you call "shity" coding in the best way it can, since nobody is perfect and "errare humanum est". If you try to validate this page, you'll see the error.
(Reporter)

Comment 3

8 years ago
By the way, when you copy&paste a table of POSTed data from Firebug to Dreamweaver CS3, this "shity" coding seems to be pasted by DW CS3 systematically.

Comment 4

8 years ago
Paolo Stefan, you are wrong!

You enable that shity coding works, which does not make webmaster learn to write correct code! They have to write it an validate it with some validator.

Try to thing a bit deeper please!
(Reporter)

Comment 5

8 years ago
(In reply to comment #4)
> Paolo Stefan, you are wrong!
> 
> You enable that shity coding works, which does not make webmaster learn to
> write correct code! They have to write it an validate it with some validator.
> 
> Try to thing a bit deeper please!

Fine, I won't waste any more time.
It's not been a pleasure. Have a nice day.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID

Comment 6

8 years ago
This looks to be wontfix based on comments on bug 151860.
You need to log in before you can comment on or make changes to this bug.