Back button and Alt+left (Backspace) does not work on gmail page.

RESOLVED WORKSFORME

Status

()

Firefox
Keyboard Navigation
RESOLVED WORKSFORME
9 years ago
2 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2b6pre) Gecko/20091229 Firefox/3.5.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091229 Minefield/3.7a1pre ID:20091229050527

Back button and  Alt+left (Backspace) des not work.
I cannot navigate back to the previous shown page on the tab.


Reproducible: Always

Steps to Reproduce:
1.Start Minefield with new profile
2.Navigate some pages.
3.Open URL ( https://mail.google.com/ ) on the same tab.
4.Log in to gmail.
5.Click Back button OR key in Alt+left (Backspace) several time

Actual Results:  
I cannot navigate back to the previous shown page.

Expected Results:  
I can navigate back to the previous shown page.

This issue doed not happen on Shiretoko.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.8pre) Gecko/20091224 Firefox/3.5.8pre ID:20091224044156
(Reporter)

Comment 1

9 years ago
In Namoroka,
Back button may work.
Alt+left (Backspace)does not work.

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.8pre) Gecko/20091224 Firefox/3.5.8pre ID:20091224044156
Version: unspecified → Trunk
(Reporter)

Comment 2

9 years ago
(In reply to comment #1)
> In Namoroka,
> Back button may work.
> Alt+left (Backspace)does not work.
> 
> Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.8pre) Gecko/20091224
> Firefox/3.5.8pre ID:20091224044156
Sorry, UA

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2b6pre) Gecko/20091229 Namoroka/3.6b6pre ID:20091229044559
Can you try in safe mode and/or a new profile? 
http://support.mozilla.com/en-US/kb/Safe+Mode
http://support.mozilla.com/en-US/kb/Managing+profiles
WFM with 3.5.7 and Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20100116 Minefield/3.7a1pre (.NET CLR 3.5.30729) ID:20100116042715

Comment 4

9 years ago
I experience the same behaviour with gmail.com as well as huffingtonpost.com 
There may be others, I don't know

Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2) Gecko/20100118 Fedora/3.6.1-0.11.rc2.fc12 Namoroka/3.6 - Build ID: 20100118165635

The back button {Navigation Bar} needs to be clicked 3 times on gmail and twice on huffingtonpost before the expected behaviour occurs.

This happens in both regular and safe mode.

Comment 5

9 years ago
I forgot to add, that I also experience the same behaviour with a new profile with no plugins, addons, personas or additional themes installed.
This is a problem with every Firefox browser, not only the latest versions so my guess is that Google changed something in his software.
Duplicate of this bug: 541143
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 8

9 years ago
Back button does not work.
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ru; rv:1.9.2.0) Gecko/20100115 SUSE/3.6.0-1.1 Firefox/3.6 GTB7.0
(Reporter)

Comment 9

9 years ago
Is Bug 534178 a duplication of this bug?

Comment 10

9 years ago
Whether it is a problem or not in previous versions of Firefox I can't confirm. I can confirm that it is a new problem that I only noticed after upgrading from a late 3.6 beta or possibly RC to 3.6 release. That may be coincidental timing. Perhaps Google changed something.

But even if the change is on Google's side, IE8 and Google Chrome do this properly and do not exhibit this bug. This is nearly a killer bug for me as a heavy email user relying on my mouse's back button to navigate gmail.

Given that other browsers do it correctly, gmail rarely changes, and the bug is coincident with a major release of Firefox, this bug certainly deserves attention.

Comment 11

9 years ago
In Firefox 3.5.6 installed on Windows XP, Back button works.
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6
Kev, do we have a contact at gmail?

Comment 13

9 years ago
Definitely something quirky going on here.

Tested on FF 3.6 final and on latest nightly (in both normal and safe mode):
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1pre) Gecko/20100123 Minefield/3.7a1pre (.NET CLR 3.5.30729)

For me, 100% of the time if I open Gmail and click on an email, then try to use the back button to return to the Inbox nothing happens until I click 3 times at which point it will go back to the site loaded PREVIOUS to opening Gmail.  However, subsequent back button attempts after viewing more emails are intermittently successful.

Here's some more interesting info:
When the back button attempt is made starting from an email view in Gmail then I DO see changes in the address bar as I press the back button.  Here is a sequence showing the changes:

1) I open Gmail and view a message; address bar reads:
https://mail.google.com/mail/?hl=en&shva=1#inbox/1265bd3bxxxxxx

2) I click on the back button once; address bar reads:
https://mail.google.com/mail/?hl=en&shva=1#

3) I click on the back button a second time; address bar reads:
https://mail.google.com/mail/?hl=en&shva=1

4) I click on the back button a third time, and the browser loads page shown previous to Gmail.

The Gmail view remains at the initial email view during this time despite the changes in the address bar (until the actual domain itself changes at the third back button press).  But then as I said above, the behavior becomes inconsistent if another email is opened after clicking on the Inbox.  Frustrating...

This NEVER happened to me on ANY Firefox version previous to 3.6

Comment 14

9 years ago
I can't stand it anymore. I'm going to stop using firefox until this is fixed.
(Reporter)

Comment 15

9 years ago
webNavigation may be broken something on Firefox3.6.x & Minefield3.7a2pre .
(Reporter)

Comment 16

9 years ago
(In reply to comment #9)
> Is Bug 534178 a duplication of this bug?

Bug 534178 is different bug because of the regression range is different.

Comment 17

9 years ago
Latest nightly still does not address this issue.  What's going on here?
(Reporter)

Comment 18

2 years ago
https://hg.mozilla.org/mozilla-central/rev/70dfd4254cf977be2000b41f7a6b97eaada8e2a0
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0 ID:20160507030302
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.