Can't nest tables easily (in editor)

VERIFIED FIXED

Status

()

Core
Editor
P1
critical
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: sujay, Assigned: kinmoz)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-][p:1][PDTP1][RTM++]FIXED IN TRUNK AND BRANCH)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
using 9/22 build of netscape

1) launch netscape
2) launch composer
3) insert default table
4) click inside the first cell
5) Insert | Table

notice the cell changes color to red..

all platforms.
(Reporter)

Comment 1

18 years ago
same problem if you click on the table icon on the toolbar...

you can nest tables if you click pulldown Table | Insert | Table
and click OK in the dialog.
(Reporter)

Comment 2

18 years ago
actually its not changing the cell color to red, its just selecting
it in the red color...
(Reporter)

Comment 3

18 years ago
changing summary of bug report.

you can only nest tables by going into  Table | Insert | Table. but it doesn't
work if you do it these ways:

1) Insert | Table
2) clicking on the Table button on the toolbar and then clicking OK in that
dialog

Summary: insert table inside a table causes cell color change → can't nest tables

Comment 4

18 years ago
I agree that using the "Table" item from the "Insert"
menu should insert a nested table. That would be trivial to change.
Using the toolbar button is "dual function" (true for all "object" buttons 
except for H.Line): they bring up properties if object is selected, in in this
case, you're inside a table.

Comment 5

18 years ago
The fix for this is as trivial as it gets:
-      <menuitem accesskey="&inserttable.accesskey;"
observes="cmd_table"       value="&insertTableCmd.label;"/>
+      <menuitem accesskey="&inserttable.accesskey;"      
observes="cmd_InsertTable" value="&insertTableCmd.label;"/>
The "cmd_InsertTable" is already being used in the Table | Insert | Table
menuitem.
Rick: Since you expressed concern about being able to insert nested tables,
would you approve this change?

Comment 6

18 years ago
nested tables are an absolute must have, setting to p1
Severity: normal → critical
Keywords: nsbeta3
Priority: P3 → P1
Whiteboard: [nsbeta3+][p:1]
Target Milestone: --- → M19

Comment 7

18 years ago
PDT:  If risk is low, as Charlie says, then we'll take this as P1.  But not a
PR3 stop ship.
Whiteboard: [nsbeta3+][p:1] → [nsbeta3+][p:1][PDTP1][RTM++]

Comment 8

18 years ago
We need to do of the following: 1) fix the nested table bug, or 2) disable the
UI for the feature.

Comment 9

18 years ago
First - I don't see the "nested table bug" that Rickg refers to. Please 
supply more info about that problem -- probably best to file a separate bug
about that.
But if that is not a problem or is easily fixable, I'd say the risk is as low 
as I could possibly imagine! Just execute a different, already existing command.

Status: NEW → ASSIGNED

Comment 10

18 years ago
The testcase is easdy to reproduce. In mail create a table by using the
Format/Table/Insert/Table... menu. Then select an empty cell. Now use the
Insert/Table... menu option to enter a nested table. Nothing happens.

Comment 11

18 years ago
I'll bet that what rick is getting on the nested table is the table properties
dialog and not the insert dialog -- I just tried his steps and that is what i get.

Rick, is the title of the dialog on the Insert|Table say 'Table Properties'

Comment 12

18 years ago
I agree with Beppe, that the basic problem is that "Insert | Table" (that's the 
top level "Insert" menu) doesn't insert a table, but brings up the property
dialog if you are already inside the table. As stated above, changeing that
command fixes most of the UI confusion. In my current build, 'Insert | Table'
*always* inserts a new table (after showing the small dialog). Please pay 
attention to what dialog comes up.
But Rick has also revealed a different problem: After the first table, he is 
*selecting* a cell before inserting the nested table. You don't have to do that
( you can just put caret in a cell), but if you do, we mangle the table: we
end up with 3 tables with the newest one in the middle (original table is split
into 2 others.) So that needs to be addressed and I am working on a very easy
fix for that.

Comment 13

18 years ago
Created attachment 15473 [details] [diff] [review]
Java Script code to fix inserting nested tables

Comment 14

18 years ago
marking nsbeta3- as this is already RTM++ and not necessary for PR3 per clayton.
Whiteboard: [nsbeta3+][p:1][PDTP1][RTM++] → [nsbeta3-][p:1][PDTP1][RTM++]

Comment 15

18 years ago
This has been fixed in the tip tree
Summary: can't nest tables → Can't nest tables easily
Whiteboard: [nsbeta3-][p:1][PDTP1][RTM++] → [nsbeta3-][p:1][PDTP1][RTM++]FIXED IN TRUNK

Comment 16

18 years ago
Reassigning to kin to checkin on the branch next week since I'm starting my
sabatical
Assignee: cmanske → kin
Status: ASSIGNED → NEW
(Assignee)

Comment 17

17 years ago
Accepting bug.
Status: NEW → ASSIGNED
Summary: Can't nest tables easily → Can't nest tables easily (in editor)

Updated

17 years ago
Keywords: rtm

Comment 18

17 years ago
r=brade, r,a=sfraser
This can go in the branch now, right?  No rush, just trying to get the branch
vs. trunk diffs I'm reviewing under control.

/be

Comment 20

17 years ago
sr=sfraser for the branch checkin.
(Assignee)

Comment 21

17 years ago
Checked fix into Netscape_20000922_BRANCH for cmanske@netscape.com:

    mozilla/editor/ui/composer/content/editorOverlay.xul   revision 1.135.2.1
    mozilla/editor/ui/dialogs/content/EdInsertTable.js     revision 1.25.6.1

r=brade@netscape.com sr,a=sfraser@netscape.com


Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Whiteboard: [nsbeta3-][p:1][PDTP1][RTM++]FIXED IN TRUNK → [nsbeta3-][p:1][PDTP1][RTM++]FIXED IN TRUNK AND BRANCH
(Reporter)

Comment 22

17 years ago
Beautiful. verified in 10/4 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.