[shared module] Create helper functions for tabbed browsing (TabbrowserAPI)

RESOLVED FIXED

Status

Mozilla QA
Mozmill Tests
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: whimboo, Assigned: whimboo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mozmill-doc-complete])

Attachments

(2 attachments, 1 obsolete attachment)

This is a bug I will use to create a complete API which helps us in using tab specific elements in the browser window.

If your test needs this API please add it to the dependency list.
Created attachment 421470 [details] [diff] [review]
Patch v1

That's much as possible as I can do for now. All of the elements we have to work with are handled via the API which makes creating tests much easier. Further I have moved the closeAllTabs and createNotificationBarElement function into that API because they are both tabbed browsing related. All tests have been updated and tests have been run on OS X, Linux, and Windows. No new regressions have been caused.
Attachment #421470 - Flags: review?(adesai)
Created attachment 422220 [details] [diff] [review]
Patch v2 [checked-in]

Small updates based on the work for the ToolbarAPI.
Attachment #421470 - Attachment is obsolete: true
Attachment #422220 - Flags: review?(adesai)
Attachment #421470 - Flags: review?(adesai)
Attachment #422220 - Attachment is patch: true
Attachment #422220 - Attachment mime type: application/octet-stream → text/plain
Attachment #422220 - Flags: review?(adesai) → review+
Landed on trunk with a follow-up fix:
http://hg.mozilla.org/qa/mozmill-tests/rev/c087982c3d7f
http://hg.mozilla.org/qa/mozmill-tests/rev/a528b53b96da

For mozmill1.9.1 a couple of changes were necessary. Would be great if you can run an additional check before I checkin the patch.
Created attachment 422444 [details] [diff] [review]
Patch (1.9.1 branch)
Attachment #422444 - Flags: review?(adesai)
Attachment #422220 - Attachment description: Patch v2 → Patch v2 [checked-in]
Whiteboard: [mozmill-doc-needed]
I'm not able to run the testPrivateBrowsing folder with this new patch. can you verify this, henrik? I don't receive any messages when using a --showall and/or a --show-errors
What didn't work? How did you run the test? No output at all? Works fine for me with a most recent Shiretoko build.
Aakash, ping?
Comment on attachment 422444 [details] [diff] [review]
Patch (1.9.1 branch)

yeah works for me now. it was a problem on my end with firefox versions
Attachment #422444 - Flags: review?(adesai) → review+
Landed on 1.9.1 as:
http://hg.mozilla.org/qa/mozmill-tests/rev/0b20105de12c
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Docs have been added:
https://developer.mozilla.org/en/Mozmill_Tests/Shared_Modules/TabbedBrowsingAPI
Whiteboard: [mozmill-doc-needed] → [mozmill-doc-complete]
Mass move of Mozmill Test related project bugs to newly created components. You can filter out those emails by using "Mozmill-Tests-to-MozillaQA" as criteria.
Component: Mozmill → Mozmill Tests
Product: Testing → Mozilla QA
QA Contact: mozmill → mozmill-tests
You need to log in before you can comment on or make changes to this bug.