Can't open Search Mail dialog

VERIFIED FIXED

Status

P1
blocker
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: scottputterman, Assigned: scottputterman)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+])

(Assignee)

Description

18 years ago
In today's debug build I can't open the Search Dialog due to the fact that 
"results.label" is not in the dtd file.

Here is a fix assuming we can get l10n permission.

Index: resources/locale/en-US/SearchDialog.dtd
===================================================================
RCS file: 
/cvsroot/mozilla/mailnews/base/search/resources/locale/en-US/SearchDialog.dtd,v
retrieving revision 1.3
diff -c -r1.3 SearchDialog.dtd
*** SearchDialog.dtd	2000/08/17 23:54:51	1.3
--- SearchDialog.dtd	2000/09/22 16:54:57
***************
*** 9,11 ****
--- 9,14 ----
  <!ENTITY searchDialogTitle.label "Search Messages">
  <!ENTITY conditionDesc.label "Search for messages which:">
  <!ENTITY conditions.label "Criteria">
+ <!ENTITY results.label "Results">
+
(Assignee)

Comment 1

18 years ago
taking the liberty of nominating for nsbeta3 and marking nsbeta3+ since we want 
search in beta3.
Severity: normal → blocker
Keywords: nsbeta3
Priority: P3 → P1
Whiteboard: [nsbeta3+]
(Assignee)

Comment 2

18 years ago
I'm not sure if this is an actual smoketest, but it would be good not to regress 
this feature.

I talked to hangas and the solution we'll probably go with is to keep the box 
around the results but remove the text.


Index: resources/content/SearchDialog.xul
===================================================================
RCS file: 
/cvsroot/mozilla/mailnews/base/search/resources/content/SearchDialog.xul,v
retrieving revision 1.23
diff -c -r1.23 SearchDialog.xul
*** SearchDialog.xul	2000/09/22 04:14:04	1.23
--- SearchDialog.xul	2000/09/22 17:17:24
***************
*** 75,81 ****
      
      <splitter id="gray_horizontal_splitter" collapse="after"  
persist="state"/>
      
!     <titledbox value="&results.label;" orient="vertical" class="dialog 
box-padded" flex="1">
         <box id="searchTermListBox" orient="vertical" flex="1">
              <tree id="threadTree" flex="1" context="threadPaneContext"/>
         </box>
--- 75,81 ----
      
      <splitter id="gray_horizontal_splitter" collapse="after"  
persist="state"/>
      
!     <titledbox orient="vertical" class="dialog box-padded" flex="1">
         <box id="searchTermListBox" orient="vertical" flex="1">
              <tree id="threadTree" flex="1" context="threadPaneContext"/>
         </box>
Keywords: smoketest

Comment 3

18 years ago
not a smoketest. removing smoketest keyword.
Keywords: smoketest

Updated

18 years ago
QA Contact: esther → laurel
(Assignee)

Comment 4

18 years ago
fix checked in.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 5

18 years ago
*** Bug 53777 has been marked as a duplicate of this bug. ***

Comment 6

18 years ago
OK using:
2000-9-26-08 N6 branch commercial build linux rh6.0
2000-09-26-09 N6 branch commercial build NT 4.0

Comment 7

18 years ago
OK  2000-09-27-11 mn6 branch commercial build mac OS 9.0
Status: RESOLVED → VERIFIED
Whiteboard: [nsbeta3+] → [nsbeta3+] branch

Updated

18 years ago
Whiteboard: [nsbeta3+] branch → [nsbeta3+] vtrunk

Updated

18 years ago
Keywords: vtrunk
Whiteboard: [nsbeta3+] vtrunk → [nsbeta3+]

Comment 8

18 years ago
Verified Fixed with win32 mozilla trunk build 100204, linux trunk build 100208
and mac trunk build 100208.  Setting bug status to Verified and removing the
vtrunk keyword. (or just removing the vtrunk keyword since the bug had already
been set to Verified before trunk verification.)
Keywords: vtrunk
Product: Browser → Seamonkey

Updated

10 years ago
Component: MailNews: Search → MailNews: Message Display
QA Contact: laurel → search
You need to log in before you can comment on or make changes to this bug.