grey color appears in cell when applying bg cell color

VERIFIED DUPLICATE of bug 26831

Status

()

Core
Editor
P1
normal
VERIFIED DUPLICATE of bug 26831
17 years ago
16 years ago

People

(Reporter: sujay, Assigned: Charles Manske)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-])

(Reporter)

Description

17 years ago
using 9/22 build of netscape

1) launch netscape
2) launch composer
3) insert default table
4) Table | Table Props
5) select Cell tab
6) select a color in color picker
7) now hit Apply in panel

notice the cell is grey and not the color you chose..

Comment 1

17 years ago
charley, is this a ramification of the color issue with preferences? Not being
able to set color to a cell, row or column is not acceptable
Keywords: correctness, nsbeta3, rtm
Priority: P3 → P1
Whiteboard: [nsbeta3+][p:1]
Target Milestone: --- → M19
(Assignee)

Comment 2

17 years ago
Sujay, you've filed exactly the same bug before!
This is the problem: Cell selection is indicated by setting the background
color, so if you use "Apply", the dialog stays up and you don't see the color.
Once you close the dialog and change the selection, the correct color appears.
So obviously this is a problem. What should we do?
Suggestions -- After setting color:
1. Remove selection so color will show.
2. Set a timer (2 seconds?) and automatically reselect the cell after that time.

or:
1. Remove selection
2. Popup up a message box with something like:
"Color for selected cells has been set.
Press OK to reselect the cells and continue.
(Color will not show)"
Con: we aren't supposed to add new strings any more.
or:
1. Change the way we select cells to not change the entire cell's color. 
That may
be difficult.
Mike: could we change the selection model *only* for not-in-focus? Can you 
think of how to show color just in border or padding region of a cell?
(That would have problems in cells with border=0, padding=0).

Comment 3

17 years ago
ahh, thanks charley for catching this one, removed nsbeta3+, setting to future
-- we can rethink the process after rtm
Keywords: rtm
Whiteboard: [nsbeta3+][p:1] → [nsbeta3-]
Target Milestone: M19 → Future

Comment 4

17 years ago
Hmmmm... so I change the color and press "Apply" but I don't actually get to see
the changes?  What is the point of the Apply button again?  What is it's purpose?
(Assignee)

Comment 5

17 years ago
Color is only one of many attribute changes that you would see change.
Look, I don't like it either and would love to change it. Any comments on 
my suggestions above?

Comment 6

17 years ago
(1) Removing the selection--this might be ok to do but then it makes it hard to
tell what you are doing if you start navigating with the dialogs buttons
(previous/next).

(2) Message box to tell the user--I don't like this idea; it just gets in the
way of what the user is trying to do.

(3) Set a timer--I don't like this idea; seems error-prone from our end and not
intuitive from the user side either.  Flashing the background seems ugly (and is
only temporary).

(4) Change the way selection of tables is rendered--this seems most promising.
One idea would be to render the selection as an outline with marching ants
(animated).  Another idea would be to dither or put a mask with diagonal stripes
on the background or something along these lines.
(Assignee)

Comment 7

17 years ago
Obviously changing the selection style is best, and can't be done for this 
version, so it looks like this problem will have to be left as "future"
Status: NEW → ASSIGNED

Comment 8

17 years ago
Adding relnoteRTM keyword, cc'ng myself
Keywords: relnoteRTM
(Assignee)

Comment 9

17 years ago
Dupping to the bug concerning not using background color for cell highlighting.

*** This bug has been marked as a duplicate of 26831 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 10

17 years ago
verified in 1/12 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.