Status

()

Firefox
General
--
critical
RESOLVED INCOMPLETE
9 years ago
7 years ago

People

(Reporter: daryl, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2011-1-30])

(Reporter)

Description

9 years ago
User-Agent:       Opera/9.80 (Macintosh; PPC Mac OS X; U; en) Presto/2.2.15 Version/10.10
Build Identifier: 3.5.6

FF was my favorite browser. However, I've switched to Opera because FF 3.5.6 is insanely slow and hangs if I leave it running for any length of time, with multiple tabs open. 

It will also often try to open a website and just sit there trying forever unless I make it quit. I then go try to open the site in Opera and it opens immediately.

I've had to file this Firefox bug report through Opera. Or I could have used Safari. Either one is better than the current version of FF.

Reproducible: Always

Steps to Reproduce:
1.Open a number of websites in tabs.
2.Leave Firefox running for hours or days. I never shut off my Mac.
3.
Actual Results:  
Sometimes even after just part of a day, Firefox will not load websites (or take forever) and will freeze on sites that are open in tabs.

Expected Results:  
Not freeze and open the website. Opera doesn't have that problem.

I found that many, many users of 3.5.6 have the same problem, whether they're on Mac or not. 

Opera is wonderful though. Way, way faster. I've transferred all my hundreds of Firefox bookmarks over to it.

When FF 3.6 is out of beta, I'm not about to install it until I see if the early adopters are happy and agree that it's an actual speed improvement. As a last attempt to stay with Firefox, I'm going back to 3.0 to see if that helps.

I've been a Firefox "evangelist" since early days. Not so much any more. I still hope Mozilla fixes the issues and drops IE to maybe 20% market share but it won't happen unless Firefox speeds up a lot and can handle staying on for more than a few hours.
Hi,

can you reproduce the issue in the Firefox Safe Mode? http://support.mozilla.com/en-US/kb/Safe+Mode
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles

You can also try to reproduce in Firefox 4 Beta 8 or later, there are many improvements in the new version, http://www.mozilla.com/en-US/firefox/all-beta.html
Whiteboard: [CLOSEME 2011-1-30]
No reply, INCOMPLETE. Please retest with Firefox 3.6.13 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.