Random Error Generated During Sync

RESOLVED WORKSFORME

Status

Cloud Services
Firefox Sync: Backend
--
minor
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: sean.thorne, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6
Build Identifier: Weave Version: 1.0rc Compatible: 1.0b3pre1 Remote: 1.0rc

Occassionally I see Firebug pop up with random errors and this is what I see:

[Exception... "'JavaScript component does not have a method named: "onEndUpdateBatch"' when calling method: [nsINavBookmarkObserver::onEndUpdateBatch]"  nsresult: "0x80570030 (NS_ERROR_XPC_JSOBJECT_HAS_NO_FUNCTION_NAMED)"  location: "JS frame :: file:///Users/sthorne/Library/Application%20Support/Firefox/Profiles/rom94ind.default/extensions/%7B340c2bbc-ce74-4362-90b5-7c26312808ef%7D/modules/util.js :: batchedSync :: line 141"  data: no]
file:///Users/sthorne/Library/Application%20Support/Firefox/Profiles/rom94ind.default/extensions/%7B340c2bbc-ce74-4362-90b5-7c26312808ef%7D/modules/util.js
Line 141

Reproducible: Always

Steps to Reproduce:
1. Open Browser
2. Leave it open
Actual Results:  
Nothing special.

Expected Results:  
No expected results.
Can't reproduce, resolving WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
OS: Mac OS X → All
Hardware: x86 → All
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.