Failure to switch to new tabs opened from links

RESOLVED WORKSFORME

Status

SeaMonkey
Tabbed Browser
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: Andy Boze, Unassigned)

Tracking

SeaMonkey 2.0 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; rv:1.9.1.8pre) Gecko/20100101 Ubuntu/9.10 SeaMonkey/2.0.2pre equivalent Firefox/3.5.4
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; rv:1.9.1.8pre) Gecko/20100101 Ubuntu/9.10 SeaMonkey/2.0.2pre

When Tabbed Browsing preference "Switch to new tabs opened from links" is selected, it appears to have no effect.

Reproducible: Always

Steps to Reproduce:
1. In Tabbed Browsing preferences, under "Tab Display" select "Switch to new tabs opened from links" and under "Link open behavior" select "A new tab in the current window".
2. Go to http://www.htmlcodetutorial.com/linking/_A_TARGET_95y98y108y97y110y107y.html and click on the link "a new window".
3. 
Actual Results:  
A new tab open, but focus remains on the original tab.

Expected Results:  
Focus should switch to the newly opened tab.

Bug also reported to occur in SM 2.0.1 on Win Vista, http://forums.mozillazine.org/viewtopic.php?p=8356855#p8356855 .
Version: unspecified → SeaMonkey 2.0 Branch

Comment 1

8 years ago
Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.8) Gecko/20100205 SeaMonkey/2.0.3 = in Windows XP SP2 works fine.

Can you try and reproduce with SeaMonkey v2.0a3 ?

Please try in Safe mode ( http://kb.mozillazine.org/Talk:Safe_Mode#Safe_Mode_in_SeaMonkey_2 ), or with a new profile ( http://kb.mozillazine.org/Profile_Manager#Creating_a_new_profile ).

Comment 2

8 years ago
(In reply to comment #1)
> Can you try and reproduce with SeaMonkey v2.0a3 ?

Wrong version, in 2.0.3 please test.
(Reporter)

Comment 3

8 years ago
Sorry, I forgot to get back to this. I tried in Safe Mode, still a problem. I'm using:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.10pre) Gecko/20100426 SeaMonkey/2.0.5pre

I don't have 2.0.3 or 2.0.4 installed, but I can if you really need me to test those version.

Comment 4

8 years ago
Section "Link open behavior" is setting for popup windows - see Help -> Help Contents -> in left section select -> Customizing SeaMonkey -> Browser Preferences -> Tabbed Browsing:

"Link open behavior: If a webpage is designed so that certain links open in a new window by default (either through the target attribute in HTML or through embedded JavaScript), you may want to override this"

To open a new panel using the mouse using setting "Open tabs instead of windows for:"

Comment 5

8 years ago
In today's update I'm seeing the same behaviour as OP. 
(This is definitely new today because I use the preference all the time)

Comment 6

8 years ago
Comment #5 should be fixed by bug 585476. I don't know how this affects the original issue reported here, but it may be worth retesting on trunk.

Comment 7

7 years ago
Works for me:
 Mozilla/5.0 (Windows; U; Windows NT 6.1; rv:1.9.1.16pre) Gecko/20101119 SeaMonkey/2.0.11pre

Works for me:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101119 SeaMonkey/2.1b2pre
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.