Fennec is NOT for n900, it's for N8xx (different releases needed)

VERIFIED INVALID

Status

Fennec Graveyard
General
--
critical
VERIFIED INVALID
8 years ago
8 years ago

People

(Reporter: Alexey Guseynov, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Opera/9.80 (X11; Linux x86_64; U; ru) Presto/2.2.15 Version/10.10
Build Identifier: RC1

Everywhere in internet I can see: "new version of Fennec would be released for n900 first", "Fennec - browser for  n900 and n8xx". Everywhere n900 is the first, but fennec is not designed to be run of n900, but to be run ONLY on n8xx. These are DIFFERENT devices and they need DIFFERENT packages. You can't make one universal package thet fits all devices.
Name of repositary you use (see bug 531876) tells us that this is package for n8xx. n900, unlike n8xx has only 256 MB rootfs. So nokia developers said, that all packages greater, than 500Kb MUST put theit files in /opt (where 2Gb partition is mounted).
Fennec with xulrunner use 30 Mb of space in rootfs, this is HALF of available space for applications, so fennec really blocks ability to install other applications.
Please, please, make SPECIAL n900 package for release version, just put files in /opt.

Reproducible: Always

Actual Results:  
rootfs is full, another applications can't be installed, SMS can't be recieved and sent (they are stored in sqlite database located in rootfs). Device is absolutely unusable.
The fennec nightly deb package will install both fennec and xulrunner to /opt right now. I see /opt/mozilla/fennec-1.0rc1  and /opt/mozilla/xulrunner-1.9.2b6pre  folders on my N900 after installing the deb packages found here:
http://ftp.mozilla.org/pub/mozilla.org/mobile/repos/1.9.2_multi/dists/chinook/extras/binary-armel/

See this blog post for instructions on installing:
http://starkravingfinkle.org/blog/2009/11/fennec-nightly-maemo-updates/

What packages are you installing and from where?
Also, do you get any errors while installing?
In general, this bug is invlaid because _does_ install on both N8X0 and N900. It is "optified" for the N900 as well.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
Agreed, the packages do work on both devices.
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Linux/Maemo → General
OS: Linux → Linux (embedded)
QA Contact: maemo-linux → general
Hardware: Other → ARM
You need to log in before you can comment on or make changes to this bug.