HTML Font changes, Compose, Variable Width

RESOLVED DUPLICATE of bug 250539

Status

Thunderbird
Message Compose Window
--
major
RESOLVED DUPLICATE of bug 250539
8 years ago
8 years ago

People

(Reporter: grafis, Unassigned)

Tracking

({fonts})

x86
Windows 7
fonts

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6
Build Identifier: Thunderbird/3.0

HTML Composition Font Changes to Variable width when replying to email.
This bug has existed since first release.
This does not exist in any competing Email Client and did not exist in Netscape email clients.

Reproducible: Always

Steps to Reproduce:
Three Scenarios where the default HTML font changes.
For all set your Default Composition HTML Font to Verdana + Small

1. reply to email
2. Start typing
3. Add a recipient to the TO: or CC; field
4. Return to Typing and the default HTML font has changed to Variable width 

1. reply to email
2. Start typing
3. Click in body of email you are replying to
4. Return to Typing and the default HTML font has changed to Variable width 

1. Compose or reply to email
2. Start typing
3. Invoke Formatting Options
4. Bullets or Text Align change the font to Variable Width

Actual Results:  
See steps to reproduce - Default HTML Composition Font changes without the user asking for a change.

Expected Results:  
Default HTML Composition Font is maintained until user changes it.

Thunderbird should use the defined HTML Composition Font for all text until the user requests otherwise.
(Reporter)

Updated

8 years ago
Version: unspecified → 3.0
(Reporter)

Updated

8 years ago
Keywords: fonts

Comment 1

8 years ago
Your third example is definitely bug 250539
You might be interested in reading through that bug, specifically
https://bugzilla.mozilla.org/show_bug.cgi?id=250539#c1
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> Your third example is definitely bug 250539
> You might be interested in reading through that bug, specifically
> https://bugzilla.mozilla.org/show_bug.cgi?id=250539#c1

Thanks Joe. 250539 has been open for 5.5 years, is unassigned and has no activity except continuing reports of the issue with each new version of Thunderbird. 

The Bug hasn't been closed, not has it been recognized. This suggests that either the right people haven't seen it or the T-Bird team does not consider HTML an important component of their client, acknowledging that the issue exists but does not warrant their time - in which case my business has picked the wrong client.

Similar bugs posted over the last 5 years that have been merged into 250539
Bug 534839 - Default font-style changes abruptly to "Variable width"
Bug 535816 - font style changes to variable width repeatedly
Bug 515488 - Thunderbird forgets or ignores composition font.
Bug 514892 - When entering bulleted or numberd list the font is restored to default
Bug 485646 - Default font lost when using indenting and bullet lists
Bug 385387 - Inconsistency in default fonts
Bug 407149 - Compose window does not always honor font selection
Bug 374573 - Thunderbird does not seem to respect font preferences when replying
Bug 390669 - Font changes if text is inserted in HTML message
Bug 413690 - Font gets change when paragraph numbering starts
Bug 435400 - Default font-style applies to text-paragraphs but not to tables and lists
Bug 408137 - font gets reset after inserting bullets or pasting image
Bug 421323 - Font size preference is not kept consistently
Bug 387570 - Selecting bulleted or numbered text switches from user's selected font to "variable width"
Bug 322857 - Default composition font lost when a bullet item is added
Bug 315867 - Font changes when starting a numbered list
Bug 310908 - When typing, the default style can not be used
Bug 291481 - Fonts at random changing from Fixed Width to Veriable Width.
Bug 292673 - Font used for lists in messages does not respect HTML message font settings
Bug 272752 - Weird compose editor behaviour
Bug 260784 - Message compositions do not retain default font size when making text a list item

Comment 3

8 years ago
Likely dupe of bug 250539.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 250539
You need to log in before you can comment on or make changes to this bug.