Consider supporting the import/export of Google Chrome bookmarks

NEW
Unassigned

Status

Camino Graveyard
Bookmarks
--
enhancement
8 years ago
6 years ago

People

(Reporter: philippe (part-time), Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 419798 [details]
very basic sample file

The file is in xml format, and located: ~/Library/Application Support/Google/Chrome/Default/Bookmarks

Comment 1

8 years ago
No reason not to...

Just out of curiosity, I tried importing the sample file as a bookmarks.xml, as a bookmarks.txt, and as a bookmarks.html file. The only difference among the three was the file extension. Our importer only dealt with the .html version, and was unable to import anything that way (no real surprise there).

cl
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: x86 → All
Version: Trunk → unspecified
(In reply to comment #0)
> Created an attachment (id=419798) [details]
> very basic sample file
> 
> The file is in xml format, and located: ~/Library/Application
> Support/Google/Chrome/Default/Bookmarks

Actually, that's JSON; all the cool kids are doing it (see bug 152147 comment 76) :P

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 505192
Sorry.  This is for Camino.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 5

8 years ago
bug 505192 is the firefox equivalent of this bug.
Status: REOPENED → NEW

Comment 6

6 years ago
In discussions about the iCab import/export patch:

<sauron> if we were to add another export format, it should be Chrome

Makes sense to do both at once, although if someone comes along and only wants to tackle import (which definitely takes priority), we can split export into another bug then.

I might have time to look at this soon-ish, but no promises.
Summary: Consider Supporting the import of Google Chrome bookmarks. → Consider supporting the import/export of Google Chrome bookmarks
You need to log in before you can comment on or make changes to this bug.