If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

intermittent failure in layout/style/test/test_transitions_events.html | unexpected event on SPAN element with id 'six' (and 'five') elapsedTime=0.5 propertyName='color'

RESOLVED WORKSFORME

Status

()

Core
CSS Parsing and Computation
P2
normal
RESOLVED WORKSFORME
8 years ago
5 years ago

People

(Reporter: tnikkel, Assigned: dbaron)

Tracking

({intermittent-failure})

Trunk
mozilla1.9.3a5
intermittent-failure
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1262497561.1262498542.10731.gz
OS X 10.5.2 mozilla-central test mochitests-4/5 on 2010/01/02 21:46:01
s: moz2-darwin9-slave11
24386 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/style/test/test_transitions_events.html | unexpected event
24387 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/style/test/test_transitions_events.html | unexpected event
(Reporter)

Comment 1

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1262497547.1262498713.12776.gz
WINNT 5.2 mozilla-central debug test mochitests-4/5 on 2010/01/02 21:45:47
s: win32-slave41
OS: Mac OS X → All
Hardware: x86 → All
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1264742449.1264744430.22831.gz
Linux mozilla-central debug test mochitests-4/5 on 2010/01/28 21:20:49
s: moz2-linux-slave26
24639 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/style/test/test_transitions_events.html | unexpected event
24640 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/style/test/test_transitions_events.html | unexpected event
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1265923109.1265928502.7856.gz
Linux mozilla-central debug test mochitests-4/5 on 2010/02/11 13:18:29
s: moz2-linux-slave10
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1265931229.1265933739.2792.gz
Linux mozilla-central opt test mochitests-4/5 on 2010/02/11 15:33:49
s: moz2-linux-slave05
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1266589461.1266591094.3904.gz
WINNT 5.2 mozilla-central opt test mochitests-4/5 on 2010/02/19 06:24:21  
s: win32-slave17
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1267058675.1267059663.9710.gz
WINNT 5.2 mozilla-central opt test mochitests-4/5 on 2010/02/24 16:44:35
s: win32-slave11
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1267167801.1267171597.599.gz
Linux mozilla-central debug test mochitests-4/5 on 2010/02/25 23:03:21
s: moz2-linux-slave16
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1267243141.1267244646.10248.gz
WINNT 5.2 mozilla-central debug test mochitests-4/5 on 2010/02/26 19:59:01
s: win32-slave15
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1267307675.1267309862.3682.gz
WINNT 5.2 mozilla-central opt test mochitests-4/5 on 2010/02/27 13:54:35
s: win32-slave23
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1267445537.1267446916.17417.gz
WINNT 5.2 mozilla-central opt test mochitests-4/5 on 2010/03/01 04:12:17
s: win32-slave23
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1267538928.1267539801.19426.gz
WINNT 5.2 mozilla-central opt test mochitests-4/5 on 2010/03/02 06:08:48
s: win32-slave43
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1267634960.1267635769.27111.gz
WINNT 5.2 mozilla-central opt test mochitests-4/5 on 2010/03/03 08:49:20
s: win32-slave20
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1267670190.1267672969.21360.gz
WINNT 5.2 mozilla-central opt test mochitests-4/5 on 2010/03/03 18:36:30
s: win32-slave20
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1267832446.1267834649.2600.gz
WINNT 5.2 mozilla-central opt test mochitests-4/5 on 2010/03/05 15:40:46
s: win32-slave19
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1267922186.1267922805.8904.gz
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268225398.1268228100.19527.gz
WINNT 5.2 mozilla-central opt test mochitests-4/5 on 2010/03/10 04:49:58
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268403452.1268406991.18088.gz
OS X 10.5.2 mozilla-central debug test mochitests-4/5 on 2010/03/12 06:17:32
(Assignee)

Comment 18

8 years ago
At some point when the tree is open I'll land
http://hg.mozilla.org/users/dbaron_mozilla.com/patches/file/3fed183581e0/transitions-events-diagnostic
to get a better error message that might lead to the problem.
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268705815.1268706397.11610.gz
WINNT 5.2 mozilla-central opt test mochitests-4/5 on 2010/03/15 19:16:55
s: win32-slave07
(Assignee)

Comment 20

8 years ago
Additional diagnostics:
http://hg.mozilla.org/mozilla-central/rev/bcf6e7436f57
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268935775.1268936975.25824.gz
WINNT 5.2 mozilla-central opt test mochitests-4/5 on 2010/03/18 11:09:35
s: win32-slave29

25536 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/style/test/test_transitions_events.html | unexpected event on SPAN element with id 'five' elapsedTime=0.5 propertyName='color'
25537 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/style/test/test_transitions_events.html | unexpected event on SPAN element with id 'six' elapsedTime=0.5 propertyName='color'
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268957379.1268962896.5673.gz
Linux mozilla-central debug test mochitests-4/5 on 2010/03/18 17:09:39
s: moz2-linux-slave26

25654 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/style/test/test_transitions_events.html | unexpected event on SPAN element with id 'five' elapsedTime=0.5 propertyName='color'
25678 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/style/test/test_transitions_events.html | unexpected event on SPAN element with id 'six' elapsedTime=0.5 propertyName='color'
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1269325025.1269325582.30611.gz
WINNT 5.2 mozilla-central opt test mochitests-4/5 on 2010/03/22 23:17:05
s: win32-slave18

25663 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/style/test/test_transitions_events.html | unexpected event on SPAN element with id 'five' elapsedTime=0.5 propertyName='color'
25664 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/style/test/test_transitions_events.html | unexpected event on SPAN element with id 'six' elapsedTime=0.5 propertyName='color'
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1269425462.1269427969.3732.gz
Linux mozilla-central debug test mochitests-4/5 on 2010/03/24 03:11:02
s: moz2-linux-slave21

25785 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/style/test/test_transitions_events.html | unexpected event on SPAN element with id 'six' elapsedTime=0.5 propertyName='color'
25786 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/style/test/test_transitions_events.html | unexpected event on SPAN element with id 'five' elapsedTime=0.5 propertyName='color'
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1269980180.1269980775.18483.gz
WINNT 5.2 mozilla-central opt test mochitests-4/5 on 2010/03/30 13:16:20
s: win32-slave29

25831 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/style/test/test_transitions_events.html | unexpected event on SPAN element with id 'six' elapsedTime=0.5 propertyName='color'
25832 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/style/test/test_transitions_events.html | unexpected event on SPAN element with id 'five' elapsedTime=0.5 propertyName='color'
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1269989851.1269990439.16814.gz
WINNT 5.2 mozilla-central opt test mochitests-4/5 on 2010/03/30 15:57:31
s: win32-slave29

25812 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/style/test/test_transitions_events.html | unexpected event on SPAN element with id 'five' elapsedTime=0.5 propertyName='color'
25813 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/style/test/test_transitions_events.html | unexpected event on SPAN element with id 'six' elapsedTime=0.5 propertyName='color'
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270154893.1270157294.16756.gz
WINNT 5.2 mozilla-central debug test mochitests-4/5 on 2010/04/01 13:48:13
s: win32-slave07

25812 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/style/test/test_transitions_events.html | unexpected event on SPAN element with id 'six' elapsedTime=0.5 propertyName='color'
25813 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/style/test/test_transitions_events.html | unexpected event on SPAN element with id 'five' elapsedTime=0.5 propertyName='color'
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270477698.1270478445.23010.gz
OS X 10.5.2 mozilla-central opt test mochitests-4/5 on 2010/04/05 07:28:18
s: moz2-darwin9-slave42

25916 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/style/test/test_transitions_events.html | unexpected event on SPAN element with id 'six' elapsedTime=0.5 propertyName='color'
25917 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/style/test/test_transitions_events.html | unexpected event on SPAN element with id 'five' elapsedTime=0.5 propertyName='color'
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270482571.1270483300.1984.gz
OS X 10.5.2 mozilla-central opt test mochitests-4/5 on 2010/04/05 08:49:31
s: moz2-darwin9-slave42
(same failures as in comment 28)
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270489294.1270490136.24185.gz
WINNT 5.2 mozilla-central opt test mochitests-4/5 on 2010/04/05 10:41:34
s: win32-slave13

25830 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/style/test/test_transitions_events.html | unexpected event on SPAN element with id 'five' elapsedTime=0.5 propertyName='color'
25831 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/style/test/test_transitions_events.html | unexpected event on SPAN element with id 'six' elapsedTime=0.5 propertyName='color'
Comment hidden (Treeherder Robot)
Duplicate of this bug: 557725
(Assignee)

Comment 33

8 years ago
I landed http://hg.mozilla.org/mozilla-central/rev/0c8ce4ebd370 , which should fix this.  Essentially it means that if we break what this test is testing, we'll end up with the test failing most of the time rather than all the time, which is ok.  We'll notice.  It's much more important that it passes all the time when things aren't broken.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Component: Layout → Style System (CSS)
Priority: -- → P2
QA Contact: layout → style-system
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a4
(Assignee)

Updated

8 years ago
Assignee: nobody → dbaron
Blocks: 531585
Flags: in-testsuite+
Re-opening, as this just failed again on tinderbox (intermittently; other runs testing the same code passed ok):

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1271323058.1271323804.21478.gz
OS X 10.5.2 mozilla-central opt test mochitests-4/5 on 2010/04/15 02:17:38
s: moz2-darwin9-slave11

25957 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/style/test/test_transitions_events.html | unexpected event on SPAN element with id 'six' elapsedTime=0.5 propertyName='color'
25958 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/style/test/test_transitions_events.html | unexpected event on SPAN element with id 'five' elapsedTime=0.5 propertyName='color'
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 37

8 years ago
Landed what I hope will fix it:
http://hg.mozilla.org/mozilla-central/rev/6a2235219b22

Optimistically marking fixed again.  Again, please reopen if it continues.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

8 years ago
Target Milestone: mozilla1.9.3a4 → mozilla1.9.3a5

Comment 38

8 years ago
104890 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/style/test/test_transitions_events.html | unexpected event on SPAN element with id 'six' elapsedTime=0.5 propertyName='color'
104895 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/style/test/test_transitions_events.html | unexpected event on SPAN element with id 'five' elapsedTime=0.5 propertyName='color'

I got these failures 3 times in a row on OpenSolaris, if I run mochitest-plain from start.
If I use TEST_PATH=layout, I can not reproduce it.

Comment 39

8 years ago
I reverted 6a2235219b22.
Now all tests passed twice in a row with the same builds on the same machine.

Comment 40

8 years ago
I guess the reason I'm still have intermittent failures, and even more failures with 6a2235219b22 is it is on the edge of transitions ends, doing cs("five"), cs("six") takes some extra time making things even worse.
Is it possible change 0.5s to a bigger value?
Comment hidden (Treeherder Robot)
But the frequency, the frequency really dropped.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey2.1/1304958799.1304962560.9143.gz
OS X 10.6 comm-2.0 debug test mochitests-4/5 on 2011/05/09 09:33:19
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Summary: intermittent failure in layout/style/test/test_transitions_events.html → intermittent failure in layout/style/test/test_transitions_events.html | unexpected event on SPAN element with id 'six' elapsedTime=0.5 propertyName='color'
(Assignee)

Updated

6 years ago
Whiteboard: [orange] → [orange][was probably fixed, but fix was backed out because it broke Solaris]
(Assignee)

Comment 127

6 years ago
(In reply to Ginn Chen from comment #39)
> I reverted 6a2235219b22.
> Now all tests passed twice in a row with the same builds on the same machine.

Please don't back things out without sending email to the person you're backing out.

I maintain that that fix was correct, and if it caused reliable failures on Solaris, there's something very broken on Solaris.

Now that I'm aware the patch was backed out, I intend to reland it.  If there are still problems on Solaris, please debug them.
(Assignee)

Comment 128

6 years ago
Sorry, I misunderstood; it appears you only reverted locally and didn't back the patch out.
Whiteboard: [orange][was probably fixed, but fix was backed out because it broke Solaris] → [orange]
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Updated

6 years ago
Summary: intermittent failure in layout/style/test/test_transitions_events.html | unexpected event on SPAN element with id 'six' elapsedTime=0.5 propertyName='color' → intermittent failure in layout/style/test/test_transitions_events.html | unexpected event on SPAN element with id 'six' (and 'five') elapsedTime=0.5 propertyName='color'
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1331876949.1331878277.32117.gz
WINNT 5.2 comm-central-trunk debug test mochitests-4/5 on 2012/03/15 22:49:09
s: cb-seamonkey-win32-01
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1334316010.1334318813.23397.gz
WINNT 5.2 comm-central-trunk debug test mochitests-4/5 on 2012/04/13 04:20:10
s: cn-sea-qm-win2k3-01

37278 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/style/test/test_transitions_events.html | unexpected event on SPAN element with id 'six' elapsedTime=0.5 propertyName='color'
37279 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/style/test/test_transitions_events.html | unexpected event on SPAN element with id 'five' elapsedTime=0.5 propertyName='color'
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Keywords: intermittent-failure
Whiteboard: [orange]
Resolving WFM keyword:intermittent-failure bugs last modified >3 months ago, whose whiteboard contains none of:
{random,disabled,marked,fuzzy,todo,fails,failing,annotated,time-bomb,leave open}

There will inevitably be some false positives; for that (and the bugspam) I apologise. Filter on orangewfm.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.