Suggestion: only load the visible tab at restart

RESOLVED DUPLICATE of bug 521964

Status

()

Firefox
Tabbed Browser
--
enhancement
RESOLVED DUPLICATE of bug 521964
8 years ago
8 years ago

People

(Reporter: Rick Leir, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6 (.NET CLR 3.5.30729)

When Firefox restarts with many tabs open, it reloads them all. Maybe it should just reload the active tab, and reload the other tabs 'lazily' when they are selected. Or just load the tabs that are currently visible in the tab bar scrolling area.

Reproducible: Always

Steps to Reproduce:
1. open 20 tabs, or enough to make the tab bar scroll
2. restart firefox
3. 
Actual Results:  
all tabs are reloaded whether visible or not

Expected Results:  
just the visible tab is reloaded

other tabs are reloaded 'lazily'

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 521964
This is a dupe of bug 514490 and is a new feature in Firefox 3.6.
Duplicate of bug: 514490

Updated

8 years ago
Duplicate of bug: 521964
You need to log in before you can comment on or make changes to this bug.