Broken mouse tracking in drop-down lists

RESOLVED WORKSFORME

Status

()

P2
major
RESOLVED WORKSFORME
18 years ago
18 years ago

People

(Reporter: pierre, Assigned: bugs)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
This is a regression introduced in the past few days that I noticed on the Mac 
and which was confirmed by Ros Spears on Win32.

Using the Classic skin, go to the Font prefs panel and play with the font name 
and font size drop-down lists. You can notice that the selected item tracks the 
mouse cursor much more slowly than before.

There is another problem that shows in the drop-down lists used in HTML Form 
controls. Go to any bug page (this one for instance), click the "Component" box 
at the top of the page: the list only shows 20 items and you can no longer make 
it scroll by moving the mouse cursor slightly out of the box, at the top or at 
the bottom. The only way to make the list scroll is to use the scrollbar.
(Reporter)

Updated

18 years ago
Keywords: regression
Priority: P3 → P2

Comment 1

18 years ago
One problem per bug report, please.  I'll take this as being about the first
problem. Since that is Classic only, ->ben.
Assignee: trudelle → ben

Comment 2

18 years ago
yes, bookmarks are also slow as hell. And: moving the
mouse cursor slowly over empty places of XHTML and XML
pages couses neary 100 percent CPU usage on my linux
box. This sucks.

This behavior was introduced with the new res/html.css file
in Linux build 2000092106 or 2000092108, and this bug
(yes, I think there is something very buggy) persists
until today.

I didn't find an other bug report, about this prob,
but I'm sure, there must be anyone (?!).

This patch resolves the prob, but I don't know, whether
it cources new probs, so...

diff -u -r res-old/html.css res/html.css
--- res-old/html.css	Wed Sep 27 07:18:00 2000
+++ res/html.css	Thu Sep 28 14:34:38 2000
@@ -505,12 +505,6 @@
   -moz-user-select: none;
 }
 
-:focus:-moz-display-comboboxcontrol-frame {
-  background-color: Highlight;
-  color: HighlightText;
-  -moz-outline: 1px dotted HighlightText;
-}
-
 option {
   min-height: 1em;
   display: block;

Comment 3

18 years ago
The slowness in dropping down is covered by bug 32920 (which is fixed by 
removing the rule from html.css), the slowness in mousing around is a bug that 
joki has with hover event processing.
(Reporter)

Comment 4

18 years ago
Stephan, thanks for the patch.
Ben, I guess you can close this bug as dup of Joki's then.

Comment 5

18 years ago
rods, I didn't see your yesterday-fix, so ... sorry... and tnx!

Comment 6

18 years ago
Marking worksforme on the slowness of the tracking. The pref for controlling
this was turned off in the trunk and in the B3 branch. (I can't find the bug
where the hierarchical hover was backed out, so I can't dup it.). 

The other point on the drag scroll in the html select is bug 32920 , as noted
above.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.