"tag" criteria invalidates the "age in days" criteria in saved search folders

RESOLVED WORKSFORME

Status

Thunderbird
Search
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: Tark Bowl, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6 (.NET CLR 3.5.30729)
Build Identifier: 2.0.0.23

In my report I use "tag" search criteria and the "age in days" one.
"tag" is in focus of this report. Issue probably reproducible with some other criteria than "age in days" as the second search criteria.

I always use 21 days as parameter for the second search criteria. Some other amount of days probably will lead to the problem as well.

Reproducible: Always

Steps to Reproduce:
1. Create a search saved folder with following filter
  uri=mailbox://nobody@Local%20Folders/sss
  scope=mailbox://nobody@Local%20Folders/Inbox
  terms=AND (tag,isn't,$label2) AND (age in days,is less than,21)
  searchOnline=false

2. Important: first "tag" then the another search criteria
3. Open the search saved folder created as above described
Actual Results:  
Search saved folder shows also messages older than 21 days.

Expected Results:  
Only mails newer than 21 days presented by saved search folder

Bug not reproducible if changing the order of search criteria in following way
first "age in days", then "tag"
WFM

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.7) Gecko/20100106 Lightning/1.0b2pre Shredder/3.0.1pre ID:20100106033159

Comment 2

7 years ago
chrizio, do you see this problem when using version 3.1?
Summary: "tag" criteria invalidates the "age in days" one in search saved folders → "tag" criteria invalidates the "age in days" criteria in saved search folders
Whiteboard: [closeme 2011-05-01]
(Reporter)

Comment 3

7 years ago
No, I can't reproduce this problem when using TB 3.1.9.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Whiteboard: [closeme 2011-05-01]
You need to log in before you can comment on or make changes to this bug.