Java Applet fails to load twice

VERIFIED FIXED

Status

Core Graveyard
Java: OJI
P3
blocker
VERIFIED FIXED
18 years ago
8 years ago

People

(Reporter: Bill Wixted, Assigned: edburns)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; m17) Gecko/20000807
Netscape6/6.0b2
BuildID:    2000080712

I'm using the Kavachart Java charting applets in HTML.  The first time the page
loads the Java applet is loaded and displayed correctly.  If I attempt to reload
the same page the Java applet does not reload.  It is somehow cached in its old
state even though the HTML parameters have all changed in the new page when i
view source.  I can demonstate this if you contact me.  Please do
(858-452-1471).  Name is Bill.

Reproducible: Always
Steps to Reproduce:
1.Place a kavachart applet on an HTML page with some parameters.
2.Display first time, displays correctly.
3.Change the parameters to the applet.
4.Refresh.
5.The applet is shown in its previous state.  It has not been reloaded and does
not reflect the new (changed) parameters.

Actual Results:  The Java applet does not reload and displays old data.

Expected Results:  Refresh should reload Java applets since they may be driven
off of HTML parameters in the page.

Comment 1

18 years ago
*** Bug 53780 has been marked as a duplicate of this bug. ***

Comment 2

18 years ago
Re-assigning to Ed Burns, module owner.
Assignee: drapeau → edburns
Confirming for edburns to have a look, because otherwise this bug is going to 
languish for another month.

Gerv
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

18 years ago
Tried this scenario with a simple example.
Loaded the applet which takes a background color parameter.
After reloading, changed the HTML page to reflect a new color.
Reloaded the page. New color shows up.

Verified this on WinNT/Win98 with FCs version of JRE (1.3.0_01)



(Assignee)

Comment 5

18 years ago
Marking fixed per rpallath's comments.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 6

18 years ago
yeah, looks good, verified fixed on windows branch build (limbo2)
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.