Disable disk cache for fennec 1.0

VERIFIED FIXED

Status

Fennec Graveyard
General
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: dougt, Assigned: dougt)

Tracking

Trunk
x86
Mac OS X

Details

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
In b5, disk cache was off.  The pref "browser.cache.disk.parent_directory" was set to some non-existent location.  After we enabled the disk cache, page load times significantly increased.  This is most likely caused by the cost of disk writes.  When I disable disk cache, page load times matches that of b5.
(Assignee)

Comment 1

8 years ago
Created attachment 420002 [details] [diff] [review]
patch v.2
Assignee: nobody → mozbugz
Attachment #420002 - Flags: review?
(Assignee)

Updated

8 years ago
Attachment #420002 - Flags: review? → review?(pavlov)
OOC, when and why was it turned on?
(In reply to comment #2)
> OOC, when and why was it turned on?

We assumed it was always turned on for Maemo. It was working on the N810. We set the cache location using the "browser.cache.disk.parent_directory" pref to a partition with a lot of free space. The N900 uses different folders and we were pointing to a non-existent folder. So we fixed that.

Since we were not explicitly disabling the disk cache, only pointing to a non-existent folder, I assume the thinking is that the folder check in the nsCacheService did _not_ fail:

http://mxr.mozilla.org/mozilla-central/source/netwerk/cache/src/nsCacheService.cpp#423

I was assuming that the check failed and we then reverted to using the profile folder to hold the cache.
(Assignee)

Comment 4

8 years ago
fwiw, microb also is not using the disk cache.
"When I disable disk cache, page load times matches that of b5."

We have Tp numbers?
(Assignee)

Comment 6

8 years ago
head-to-head comparisons using a n900 over a half a dozen sites.
(Assignee)

Updated

8 years ago
Attachment #420002 - Flags: review?(pavlov) → review?(mark.finkle)
Comment on attachment 420002 [details] [diff] [review]
patch v.2

Yes, I have seen faster page loads with this setting.
Attachment #420002 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 8

8 years ago
http://hg.mozilla.org/mobile-browser/rev/3877bec117f2
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
verified FIXED on builds:

Mozilla/5.0 (X11; Linux armv7l; en-US; rv:1.9.2) Gecko/20100105 Firefox/3.6
Fennec/1.0

and

Mozilla/5.0 (X11; Linux armv6l; en-US; rv:1.9.2) Gecko/20100105 Firefox/3.6
Fennec/1.0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.