Add sortkey for components

VERIFIED DUPLICATE of bug 317051

Status

()

Bugzilla
Administration
--
enhancement
VERIFIED DUPLICATE of bug 317051
8 years ago
5 years ago

People

(Reporter: tmyoung, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
Would it be possible to add the ability to sort the component list on a Bugzilla product for the enter_bug.cgi file and other scripts?

I have a product that lists 20+ components; since the list is sorted alphabetically, I can't move components that are filed more frequently to the top of the list.

This would also help with "General" components, which often should go to the top of the component list so that new users who aren't sure where to file bugs are more likely to put them in the General component for triage.

Comment 1

8 years ago
This looks pretty confusing to me. In a 20+ items list, I expect the list to be sorted alphabetically, else I have no idea where to look for. The list just appears random.
(Reporter)

Comment 2

8 years ago
Would it be a problem if the list defaulted to being alphabetical (if no sortkey was set) but an administrator had the option to change it if needed?
(Reporter)

Comment 3

8 years ago
Another option would be to allow an administrator to set a "defaultSelected" property, so that a General component is selected by default.

Comment 4

8 years ago
Yeah, I think that for components, it's better to allow a default to be picked, instead of doing a sortkey.... At least, that's my opinion for now.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 317051
(Reporter)

Comment 5

8 years ago
I think that is best.  I have a jetpack which covers my needs for the moment.  So I'm covered until Bug 317051 is fixed.  Thank you as always for the help.
Status: RESOLVED → VERIFIED
Duplicate of this bug: 792411
You need to log in before you can comment on or make changes to this bug.