Browser freezes (hangs) when inputing invalid url

RESOLVED INCOMPLETE

Status

()

--
minor
RESOLVED INCOMPLETE
9 years ago
8 years ago

People

(Reporter: mailto.vondo, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2b5) Gecko/20091204 Firefox/3.6b5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2b5) Gecko/20091204 Firefox/3.6b5 (.NET CLR 3.5.30729)

When inputing invalid address to address bar, browser freezes. Freeze can last from two seconds up twenty seconds and meantime you can't use any other tab because the browser doesn't repond. 

Even though I marked this "Happens sometimes, but not always." it's more common to have frozen browser than immediately given error message.

Sometimes this happens also with valid non-existing url, but that's hard to reprodure.

Reproducible: Sometimes

Steps to Reproduce:
1.Enter invalid url E.g. http://www.asdra98n
2.Tried also another: http://www.hasdas.
3.
Actual Results:  
1. Browser freezed approx. for ten seconds.
2. Browser freezed for less ten seconds.

Expected Results:  
browser to freeze from one to twenty seconds, the everything works normal.
(Reporter)

Updated

9 years ago
Version: unspecified → 3.6 Branch
WFM with Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20100105 Minefield/3.7a1pre (.NET CLR 3.5.30729) ID:20100105042553. Can you create a new profile and test there? http://support.mozilla.com/en-US/kb/Managing+profiles
(Reporter)

Comment 2

9 years ago
Hi

I created a new profile and followed the step to reproduce the problem. I used the same invalid address (http://www.asdra98n) and the browser froze for more than 10 seconds. It also freezes all the other tabs open in the same browser window, I couldn't even select them.

br,
Lasse

Comment 3

8 years ago
WFM with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 ID:20101203075014

Reporter -> Are you still experiencing this issue with the latest version of Firefox?

Comment 4

8 years ago
Closing bug as Incomplete - if you are still experiencing this issue or have more information to provide feel free to post back here and we can re-open the bug. You can also get assistance by visiting the Firefox help site -> http://support.mozilla.com/en-US/kb/Ask+a+question
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.