If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Allow use of Mac address book groups during mail creation

RESOLVED WORKSFORME

Status

Thunderbird
Address Book
--
enhancement
RESOLVED WORKSFORME
8 years ago
2 years ago

People

(Reporter: Rick Farabaugh, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.5) Gecko/20091204 Thunderbird/3.0

Currently the only way I can see for creating a message to a group of addresses from the Mac address book is to highlight the group in the TB address book and click on the "Write" icon at the top of that page.  The behavior with groups from the TB address book allows you to simply type the group name.

The enhancement I'm asking for would have TB treat groups from the Mac address book in the same way it treats those from it's own address book.

Reproducible: Always

Steps to Reproduce:
1. create a group in the mac address book
2. open TB address book
3. select group from Mac addrtess book
4. select "Write" from TB address book

(You will get a message creation pane with all the addresses from the Mac address book group)

5. select "Write" from the main TB pane.
6. type the name from the Mac address book
Actual Results:  
TB will not find the name from the Mac address book.

Expected Results:  
TB should find that name and allow a message to be sent to all the email addresses in that group.
Didn't find any duplicates.
Status: UNCONFIRMED → NEW
Component: Message Compose Window → Address Book
Ever confirmed: true
QA Contact: message-compose → address-book
Does this still reproduce?
Flags: needinfo?(leofigueres)

Comment 3

2 years ago
It seems to be working good to me.

I created a new group of addresses directly on Mac OS X Contacts app. Added some addresses to it. On Thunderbird (tested on latest 38 beta 6 build), click on Write. On the new dialog box, start typing the name of the list (in my case "pirates") is auto-completing the field to "pirates <pirates>".

Tested on Mac OS X 10.10.3, don't know if it is not working good on previous releases of OS X (even on the same 10.10, but previous ones).

Although I was unable to reproduce, I am not exactly sure if it should be closed.
Flags: needinfo?(leofigueres)
Thanks. I think close WFM and if someone disagrees we can reopen.
If original failure is related to (older) OS X version there's not  much we can do
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.