The default bug view has changed. See this FAQ.

Moving FILE_ILLEGAL_CHARACTERS from nsCRT.h to nsCRTGlue.h for frozen linkages

RESOLVED FIXED in mozilla1.9.3a3

Status

()

Core
XPCOM
--
trivial
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: ul, Assigned: ul)

Tracking

({verified1.9.1, verified1.9.2})

Trunk
mozilla1.9.3a3
verified1.9.1, verified1.9.2
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(status1.9.2 .2-fixed, status1.9.1 .9-fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.6) Gecko/20091206 SeaMonkey/2.0.1
Build Identifier: 

need to include nsCRT.h in mailnews/base/public/msgCore.h to circumvent redefinition. This macros need to be uniquely accessible even after frozen linkage.

Reproducible: Always

Actual Results:  
Macro available through inclusion of "nsCRT.h"

Expected Results:  
single source to be included. "nsCRTGlue.h"

bug 525463
(Assignee)

Updated

7 years ago
Blocks: 525463
Blocks: 467015
(Assignee)

Comment 1

7 years ago
Created attachment 425723 [details] [diff] [review]
Moved FILE_ILLEGAL_CHARACTERS to nsCRTGlue.h
(Assignee)

Updated

7 years ago
Attachment #425723 - Flags: review?(jonas)
Assignee: nobody → ul.mcamafia
Severity: normal → trivial
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: in-testsuite-
Version: unspecified → Trunk
(Assignee)

Comment 2

7 years ago
Any other candidates to be included in this move for frozen linkage?
(Assignee)

Comment 3

7 years ago
See also:

https://bugzilla.mozilla.org/show_bug.cgi?id=525463#c6
Comment on attachment 425723 [details] [diff] [review]
Moved FILE_ILLEGAL_CHARACTERS to nsCRTGlue.h

I really don't know enough about how we want to structure these header files to know where the right place to put this in is.
Attachment #425723 - Flags: review?(jonas) → review?(benjamin)

Comment 5

7 years ago
pinging for review, since it's blocking a mailnews review...
Attachment #425723 - Flags: review?(benjamin) → review+
(Assignee)

Updated

7 years ago
Attachment #425723 - Flags: superreview?(shaver)
(Assignee)

Comment 6

7 years ago
This patch will be needed on branches 1.9.1 and 1.9.2 too after baking on trunk
Comment on attachment 425723 [details] [diff] [review]
Moved FILE_ILLEGAL_CHARACTERS to nsCRTGlue.h

sure; rs=shaver
Attachment #425723 - Flags: superreview?(shaver) → superreview+
(Assignee)

Updated

7 years ago
Keywords: checkin-needed
Checked in: http://hg.mozilla.org/mozilla-central/rev/1dcea1cb129d
Keywords: checkin-needed
(Assignee)

Updated

7 years ago
Attachment #425723 - Flags: approval1.9.2.2?
Attachment #425723 - Flags: approval1.9.1.9?
(Assignee)

Updated

7 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a3
No longer blocks: 467015
Comment on attachment 425723 [details] [diff] [review]
Moved FILE_ILLEGAL_CHARACTERS to nsCRTGlue.h

a=beltzner for branches, someone please send 'er over.
Attachment #425723 - Flags: approval1.9.2.2?
Attachment #425723 - Flags: approval1.9.2.2+
Attachment #425723 - Flags: approval1.9.1.9?
Attachment #425723 - Flags: approval1.9.1.9+
(Assignee)

Updated

7 years ago
Keywords: checkin-needed
Whiteboard: [checkin to mozilla-1.9.2] [checkin to mozilla-1.9.1]
https://hg.mozilla.org/releases/mozilla-1.9.1/rev/2e523d1e398b
https://hg.mozilla.org/releases/mozilla-1.9.2/rev/03ebb7b90df8
status1.9.1: --- → .9-fixed
status1.9.2: --- → .2-fixed
Keywords: checkin-needed
Whiteboard: [checkin to mozilla-1.9.2] [checkin to mozilla-1.9.1]
(Assignee)

Updated

7 years ago
Keywords: verified1.9.1, verified1.9.2
You need to log in before you can comment on or make changes to this bug.