Mail & Newsgroups keyboard shortcut not working

RESOLVED WONTFIX

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED WONTFIX
8 years ago
7 days ago

People

(Reporter: jenzed, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
On the "Window" drop-down menu, there is a menu item to access "Mail & Newsgroups". Neither that menu item (nor the associated keyboard shortcut) does anything.
(In reply to comment #0)
> On the "Window" drop-down menu, there is a menu item to access "Mail &
> Newsgroups". Neither that menu item (nor the associated keyboard shortcut) does
> anything.

If you open the address book this menu item will be functional. As well as if you hide the windows (using the yellow button).

Did I miss something from your repport Jen ?
Bug 534814, no? (Could sure use a 1 day regression range.)
(Reporter)

Comment 3

8 years ago
Right. But if only one TB window is opened, shouldn't the "Mail &
Newsgroups" menu item / shortcut be disabled? 

(Phil, it works fine if there are multiple windows open so I don't think it's related to bug 534814)
Ah, I misunderstood, and you actually _did_ mean to file "The Mac platform standard for having an enabled Window menuitem for the current windowtype, which unpredictably will either do nothing or maybe will actually close the window (see Safari, Window - Downloads, Window - Downloads then Window - Activity, Window - Activity) is confusing"? I'd agree with that.

However, based on what I see in Safari, and Mail.app, and Colloquy, and Camino, and DVD Player, and iTunes, and then I got bored with looking, I don't see any platform standard that would call for the M&N item to be disabled while a 3pane is frontmost, but rather a platform consensus that it must be there and enabled, and should randomly either close the window or not. I could see an argument for closing the addressbook when you choose its menuitem while it's open, though a weakish one, and a much weaker one that the 3pane should close from its menuitem (iTunes was the only one I saw that closed its primary window that way, rather than just (some but maybe not all) secondary windows). And I can see a strong argument that the platform consensus should instead be to do something else, either disable it and drop the closing feature or to always make it close, but unfortunately Thunderbird is about the last place to start driving an OS X design change.

Comment 5

7 years ago
i would agree with the last comment, and think this bug should be closed as "WONTFIX" (since i'm tired of it popping up in my search for bugs like bug 207510 , bug 429824, bug 655989 et al)

Comment 6

7 days ago
What do you guys think about closing this?
Flags: needinfo?(vseerror)
Flags: needinfo?(richard.marti)
I defer to those with more knowledge about how this should work on (or not) Mac. But it does sound like are saying this isn't needed on Mac.
Flags: needinfo?(vseerror)
Status: NEW → RESOLVED
Last Resolved: 7 days ago
Flags: needinfo?(richard.marti)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.