Pages using SSI content are flattened

RESOLVED WORKSFORME

Status

SeaMonkey
Composer
--
enhancement
RESOLVED WORKSFORME
8 years ago
6 years ago

People

(Reporter: Trevor, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.6) Gecko/20091206 SeaMonkey/2.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.6) Gecko/20091206 SeaMonkey/2.0.1

When I navigate to the page I want to edit on my site, and then go to File > Edit Page, I can start editing fine. When I am finished with all my edits and want to publish them, I can't just follow the application's standard 'publish' procedure, since this will publish a 'flattened' version of the page to my server.

Sea Monkey would be sooo much better with a helping hand to those who want to edit pages from a site that are built in a dynamic or non-flat way (because they either use PHP, or SSI, or whatever). MOST web pages are built this way!!! / Most web pages are not flat.

Suggested solutions to this problem:
1. When using the Edit function, in the source view, the content that has been added to the live page by use of SSIs or some other non-flat method is colored differently, or grayed out. This makes it easier for the editor to see what code is content code, and what code is page template code.

OR 

2. In the standard Edit view, or in the Preview, the page looks like it would look when live (with the edits - as is currently the case, which of course is a mixture of live page content called from the server and local cache content), but in the Source Code view / tab, SeaMonkey can have a user preference set to ignore any content called to the page via SSI or any non-flat method, so all you see is the source code for the content markup (ignoring page template markup). This suggestion means people like me can roll out SeaMonkey as our work wysiwyg tool for all staff, in such a way that they can edit pages, see what they'll get on the live page, jump to the source tab, copy the source code for the CONTENT ONLY and then paste it into an appropriate file on the server using FTP software. 

3. Some other suggestion that I'm not clever enough to come up with!

Trevor. I work for a charity in the UK. I used to work in web publishing, and have previously contributed to the consultation phase of WCAG 2.0. I believe in standards and helping others. Please look at this issue! Cheers ;)

I end this report with an example of what non-flat page from the development area of my site kinda looks like:

<!--#set var="SECTIONNAME" value="Peace House" -->
<!--#set var="PAGEKEYWORDS" value="peace, house, hire, venue, oxford, uk, affordable, charity, ngo, meditation, new, age, alternative, excellence, centre, academic, politic, research, book, now, bookings" -->
<!--#set var="DESCRIPTION" value="" -->
<!--#set var="PAGETITLE" value="Book Now" -->
<!--#include virtual="includes/header.shtml"-->
<!--#include virtual="includes/stylesheets.shtml"-->
<!--#include virtual="includes/body.shtml"-->

<div id="left">
<!-- Put content for the left hand side of the page below this line -->
<ul id="inline_nav">


<li><a href="bookings.shtml">intro</a></li>
    
		 

<li class="active">book now</li>
    


<li><a href="spaces.shtml">spaces</a></li>

    




<li><a href="notes.shtml">important notes</a></li>
    




<li><a href="gear.shtml">equipment</a></li>
    




<li><a href="pheco.shtml">green</a></li>
    


<li><a href="phfeedback.shtml">feedback</a></li>
    		 
		 
</ul>


<p><a href="bookingform.shtml" title="online booking request form"><img src="/peacehouse/images/form.gif" alt="web form" style="float: left; margin-right: 5px; border: 0;"/>Launch online booking request form</a></p>
<p>&nbsp;</p>



<h2>how to book</h2> 
<ul>
<li>decide which <a href="spaces.shtml">space(s)</a> you are interested in hiring</li>
<li><a href="diary.shtml">check rough availability</a> for the dates you have in mind</li>
<li>get in touch either through the <a href="bookingform.shtml" title="launch online booking form">booking request form</a>, or the <a href="phcontact.shtml" title="contact form">contact form</a>.</li> 
</ul>




</div>
<!-- All of the content on the #left hand side of the page ends here -->

<!--#include virtual="includes/menufooter.shtml"-->
<!-- This is the end of the page -->



  

Reproducible: Always

Steps to Reproduce:
1.As above
2.
3.

Comment 1

6 years ago
Could you check this against SM2.3 and see if it has improved any?

Comment 2

6 years ago
On trunk, page code doesn't change when publishing, feel free to reopen with proper testcase, if you still see this
User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0 SeaMonkey/2.13a1
Build identifier: 20120712003002
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.