Closed Bug 538049 Opened 12 years ago Closed 12 years ago

nanojit: problem with qjoin in ExprFilter

Categories

(Core Graveyard :: Nanojit, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: n.nethercote, Assigned: n.nethercote)

Details

(Whiteboard: fixed-in-nanojit, fixed-in-tracemonkey)

Attachments

(1 file)

Attached patch patchSplinter Review
The problem is that the result is being inserted as a LIR_quad instead of a LIR_float as it should be.  Came up as an assertion failure in the i386 backend on lirasm --random.

Attached patch should fix it.
Attachment #420214 - Flags: review?(stejohns)
Attachment #420214 - Flags: review?(stejohns) → review+
http://hg.mozilla.org/tracemonkey/rev/3d1913a88149
Whiteboard: fixed-in-nanojit → fixed-in-nanojit, fixed-in-tracemonkey
http://hg.mozilla.org/mozilla-central/rev/3d1913a88149
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.