Closed Bug 538056 Opened 10 years ago Closed 10 years ago

Signal handler for FPU exception is broken for Windows x64

Categories

(Toolkit Graveyard :: Build Config, defect)

x86_64
Windows Vista
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: m_kato, Assigned: Mook)

References

Details

Attachments

(1 file)

CONTEXT for x64 platform is different for x86.  There is no FloatSave member in CONTEXT for x64.  We should access it via FltSave on x64 build.
Summary: Signal handler for FPU excetion is broken for Windows x64 → Signal handler for FPU exception is broken for Windows x64
Attached patch use FltSaveSplinter Review
I had this lying around and just needed a small update, so might as well put it up.  (Please do take the patch and modify it as necessary - I won't be able to keep updating it frequently, since the toolchain I really want had a regression and doesn't build.)

Note that while this compiles, I haven't checked to be sure there are no other things that need to be saved.
Attachment #420267 - Flags: review?(m_kato)
Attachment #420267 - Flags: review?(m_kato) → review+
Attachment #420267 - Flags: review?(benjamin)
Assignee: m_kato → mook.moz+mozbz
Attachment #420267 - Flags: review?(benjamin) → review+
Keywords: checkin-needed
http://hg.mozilla.org/mozilla-central/rev/badc9da7c09c
Status: NEW → RESOLVED
Closed: 10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.